# CVE-2025-52562: Convey Panel Directory Traversal in LocaleController leading to Remote Code Execution

> Unauthenticated attackers can exploit a directory traversal flaw in the LocaleController to execute arbitrary PHP code on the server.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** GHSA-43g3-qpwq-hfgg

## What is CVE-2025-52562?

CVE-2025-52562 is a critical path traversal vulnerability in ConvoyPanel panel, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Convoy is a KVM server management panel for hosting businesses. In versions 3.9.0-rc3 to before 4.4.1, there is a directory traversal vulnerability in the LocaleController component of Performave Convoy. An unauthenticated remote attacker can exploit this vulnerability by sending a specially crafted HTTP request with malicious locale and namespace parameters. This allows the attacker to include and execute arbitrary PHP files on the server. This issue has been patched in version 4.4.1. A temporary workaround involves implementing strict Web Application Firewall (WAF) rules to incoming requests targeting the vulnerable endpoints.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-52562?


## How do I fix CVE-2025-52562?

No fix has been published for CVE-2025-52562 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-52562 being exploited?

There is no known exploitation of CVE-2025-52562 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52562 and fix it if it is affected.

What it is: CVE-2025-52562 is a critical path traversal vulnerability in ConvoyPanel panel, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52562 in the wild and no public exploit code.

Affected product: ConvoyPanel panel. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52562/ (Markdown: https://insights.sbomify.com/CVE-2025-52562/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52562
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52562
- OSV: https://osv.dev/vulnerability/CVE-2025-52562

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52562/
Summaries are generated and may contain mistakes; the official description above is the record.
