CVE-2025-52567 GLPI has overly permissive URL verification
Attackers can exploit SSRF in GLPI via RSS feeds or external calendars to access internal resources or bypass security controls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-52567?
CVE-2025-52567 is a low-severity server-side request forgery vulnerability in Glpi-Project Glpi, published on 30 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. In versions 0.84 through 10.0.18, usage of RSS feeds or external calendars when planning is subject to SSRF exploit. The previous security patches provided since GLPI 10.0.4 were not robust enough for certain specific cases. This is fixed in version 10.0.19.
Weakness: CWE-918
Which versions are affected by CVE-2025-52567?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2025-52567?
No fix has been published for CVE-2025-52567 yet. Limit exposure of the affected software until one is available.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-52567 being exploited?
There is no known exploitation of CVE-2025-52567 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-5mp6-mgmh-vrq7, UBUNTU-CVE-2025-52567.