{"answers":{"affected":"4 open source packages ship an affected version, including letmeind and letmeinfwd.","exploited":"There is no known exploitation of CVE-2025-52570 in the wild and no public exploit code.","fix":"Upgrade letmeind to 10.2.1 or later.","what":"CVE-2025-52570 is a low-severity denial of service vulnerability in mbuesch letmein, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-52570 and fix it if it is affected.\n\nWhat it is: CVE-2025-52570 is a low-severity denial of service vulnerability in mbuesch letmein, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-52570 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- letmeind (crates.io): affected all versions; fixed in 10.2.1\n- letmeind (crates.io): affected all versions; fixed in 10.2.1\n- letmeinfwd (crates.io): affected all versions; fixed in 10.2.1\n- letmeinfwd (crates.io): affected all versions; fixed in 10.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52570/ (Markdown: https://insights.sbomify.com/CVE-2025-52570/index.md)","id":"CVE-2025-52570","markdown":"https://insights.sbomify.com/CVE-2025-52570/index.md","name":"CVE-2025-52570","record":{"aliases":["GHSA-jpv7-p47h-f43j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"port knocker","requires_auth":"none","summary":"An attacker can exhaust resources by opening unlimited simultaneous connections because the connection limiter fails to enforce limits.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":1.7,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-799","name":"Improper Control of Interaction Frequency"},{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Letmein is an authenticating port knocker. Prior to version 10.2.1, The connection limiter is implemented incorrectly. It allows an arbitrary amount of simultaneously incoming connections (TCP, UDP and Unix socket) for the services letmeind and letmeinfwd. Therefore, the command line option num-connections is not effective and does not limit the number of simultaneously incoming connections. This issue has been patched in version 10.2.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Letmein connection limiter allows an arbitrary amount of simultaneous connections","id":"CVE-2025-52570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"Hikka vulnerable to RCE through edits in a channel","id":"CVE-2025-52571"},"packages":[{"ecosystem":"crates.io","fixed":["10.2.1"],"introduced":["0"],"last_affected":[],"package":"letmeind","purl":null,"source":"GHSA-jpv7-p47h-f43j"},{"ecosystem":"crates.io","fixed":["10.2.1"],"introduced":["0"],"last_affected":[],"package":"letmeind","purl":"pkg:cargo/letmeind","source":"GHSA-jpv7-p47h-f43j"},{"ecosystem":"crates.io","fixed":["10.2.1"],"introduced":["0"],"last_affected":[],"package":"letmeinfwd","purl":null,"source":"GHSA-jpv7-p47h-f43j"},{"ecosystem":"crates.io","fixed":["10.2.1"],"introduced":["0"],"last_affected":[],"package":"letmeinfwd","purl":"pkg:cargo/letmeinfwd","source":"GHSA-jpv7-p47h-f43j"}],"prev":{"headline":"GitHub.jl lacks validation for user-provided fields","id":"CVE-2025-52569"},"products":["letmein"],"published":"2025-06-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-24","vendors":["mbuesch"]},"summary":"An attacker can exhaust resources by opening unlimited simultaneous connections because the connection limiter fails to enforce limits.","url":"https://insights.sbomify.com/CVE-2025-52570/"}