# CVE-2025-52570: Letmein connection limiter allows an arbitrary amount of simultaneous connections

> An attacker can exhaust resources by opening unlimited simultaneous connections because the connection limiter fails to enforce limits.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** GHSA-jpv7-p47h-f43j

## What is CVE-2025-52570?

CVE-2025-52570 is a low-severity denial of service vulnerability in mbuesch letmein, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Letmein is an authenticating port knocker. Prior to version 10.2.1, The connection limiter is implemented incorrectly. It allows an arbitrary amount of simultaneously incoming connections (TCP, UDP and Unix socket) for the services letmeind and letmeinfwd. Therefore, the command line option num-connections is not effective and does not limit the number of simultaneously incoming connections. This issue has been patched in version 10.2.1.

Weakness: CWE-799 (Improper Control of Interaction Frequency), CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-52570?

4 open source packages ship an affected version, including letmeind and letmeinfwd.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `letmeind` | crates.io | All versions | 10.2.1 |
| `letmeind` | crates.io | All versions | 10.2.1 |
| `letmeinfwd` | crates.io | All versions | 10.2.1 |
| `letmeinfwd` | crates.io | All versions | 10.2.1 |

## How do I fix CVE-2025-52570?

Upgrade letmeind to 10.2.1 or later.

## Is CVE-2025-52570 being exploited?

There is no known exploitation of CVE-2025-52570 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52570 and fix it if it is affected.

What it is: CVE-2025-52570 is a low-severity denial of service vulnerability in mbuesch letmein, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52570 in the wild and no public exploit code.

Affected packages and fixed versions:
- letmeind (crates.io): affected all versions; fixed in 10.2.1
- letmeind (crates.io): affected all versions; fixed in 10.2.1
- letmeinfwd (crates.io): affected all versions; fixed in 10.2.1
- letmeinfwd (crates.io): affected all versions; fixed in 10.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52570/ (Markdown: https://insights.sbomify.com/CVE-2025-52570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52570
- OSV: https://osv.dev/vulnerability/CVE-2025-52570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52570/
Summaries are generated and may contain mistakes; the official description above is the record.
