# CVE-2025-52571: Hikka vulnerable to RCE through edits in a channel

> An unauthenticated attacker can bypass authentication to take over a victim's Telegram account and execute code on the server.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** GHSA-vwpq-wm8w-44wf

## What is CVE-2025-52571?

CVE-2025-52571 is a critical authentication bypass vulnerability in hikariatama Hikka, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Hikka is a Telegram userbot. A vulnerability affects all users of versions below 1.6.2, including most of the forks. It allows an unauthenticated attacker to gain access to Telegram account of a victim, as well as full access to the server. The issue is patched in version 1.6.2. No known workarounds are available.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-52571?


## How do I fix CVE-2025-52571?

No fix has been published for CVE-2025-52571 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-52571 being exploited?

There is no known exploitation of CVE-2025-52571 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52571 and fix it if it is affected.

What it is: CVE-2025-52571 is a critical authentication bypass vulnerability in hikariatama Hikka, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-52571 in the wild and no public exploit code.

Affected product: hikariatama Hikka. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52571/ (Markdown: https://insights.sbomify.com/CVE-2025-52571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52571
- OSV: https://osv.dev/vulnerability/CVE-2025-52571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52571/
Summaries are generated and may contain mistakes; the official description above is the record.
