# CVE-2025-52662: Nuxt DevTools vulnerable to cross-site scripting (XSS)

> An XSS vulnerability in Nuxt DevTools could allow attackers to extract authentication tokens under specific configurations.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-xmq3-q5pm-rp26

## What is CVE-2025-52662?

CVE-2025-52662 is a medium-severity cross-site scripting vulnerability in Vercel Nuxt Devtools, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability in Nuxt DevTools has been fixed in version **2.6.4***. This issue may have allowed Nuxt auth token extraction via XSS under certain configurations. All users are encouraged to upgrade.

More details: https://vercel.com/changelog/cve-2025-52662-xss-on-nuxt-devtools

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-52662?

2 open source packages ship an affected version, including @nuxt/devtools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nuxt/devtools` | npm | All versions | 2.6.4 |
| `@nuxt/devtools` | npm | All versions | 2.6.4 |

Products: Nuxt Devtools.

## How do I fix CVE-2025-52662?

Upgrade @nuxt/devtools to 2.6.4 or later.

## Is CVE-2025-52662 being exploited?

There is no known exploitation of CVE-2025-52662 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52662 and fix it if it is affected.

What it is: CVE-2025-52662 is a medium-severity cross-site scripting vulnerability in Vercel Nuxt Devtools, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-52662 in the wild and no public exploit code.

Affected packages and fixed versions:
- @nuxt/devtools (npm): affected all versions; fixed in 2.6.4
- @nuxt/devtools (npm): affected all versions; fixed in 2.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52662/ (Markdown: https://insights.sbomify.com/CVE-2025-52662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52662
- OSV: https://osv.dev/vulnerability/CVE-2025-52662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52662/
Summaries are generated and may contain mistakes; the official description above is the record.
