{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-5275 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-5275 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-5275 is a medium-severity cross-site scripting vulnerability in smub Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations \u0026 More, published on 26 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-5275 and fix it if it is affected.\n\nWhat it is: CVE-2025-5275 is a medium-severity cross-site scripting vulnerability in smub Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations \u0026 More, published on 26 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-5275 in the wild and no public exploit code.\n\nAffected product: smub Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations \u0026 More. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5275/ (Markdown: https://insights.sbomify.com/CVE-2025-5275/index.md)","id":"CVE-2025-5275","markdown":"https://insights.sbomify.com/CVE-2025-5275/index.md","name":"CVE-2025-5275","record":{"aliases":["GHSA-jj56-99pp-w4hp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress donation plugin","requires_auth":"high_privilege","summary":"Administrators can inject scripts via privacy settings in multi-site or restricted HTML environments, leading to stored XSS.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"charitable","vendor":"wpbeginner"}],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations \u0026 More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the privacy settings fields in all versions up to, and including, 1.8.6.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.\r\nThis issue was partially fixed in version 1.8.6.1 and fully fixed in version 1.8.6.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Charitable \u003c= 1.8.6.1 - Authenticated (Administrator+) Stored Cross-Site Scripting via Plugin's Privacy Settings","id":"CVE-2025-5275","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Markdownify MCP Server allows Server-Side Request Forgery (SSRF) via the Markdownify.get() function","id":"CVE-2025-5276"},"packages":[],"prev":{"headline":"Markdownify MCP Server allows attackers to read arbitrary files","id":"CVE-2025-5273"},"products":["Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations \u0026 More"],"published":"2025-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["smub"]},"summary":"Administrators can inject scripts via privacy settings in multi-site or restricted HTML environments, leading to stored XSS.","url":"https://insights.sbomify.com/CVE-2025-5275/"}