# CVE-2025-5279: Issue with Amazon Redshift Python Connector and the BrowserAzureOAuth2CredentialsProvider plugin

> An attacker can intercept access tokens by exploiting skipped SSL validation in the BrowserAzureOAuth2CredentialsProvider plugin of the Amazon Redshift Python connector.

- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2025
- **Updated:** 14 Oct 2025
- **Also known as:** CLEANSTART-2026-GH44642, ECHO-5e25-20a4-1de0, GHSA-r244-wg5g-6w2r, MINI-3mx4-3795-g79r, PYSEC-2026-1867, ROOT-APP-PYPI-CVE-2025-5279

## What is CVE-2025-5279?

CVE-2025-5279 is a high-severity vulnerability in Amazon Redshift, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When the Amazon Redshift Python Connector is configured with the BrowserAzureOAuth2CredentialsProvider plugin, the driver skips the SSL certificate validation step for the Identity Provider. An insecure connection could allow an actor to intercept the token exchange process and retrieve an access token.

This issue has been addressed in driver version 2.1.7. Users should upgrade to address this issue and ensure any forked or derivative code is patched to incorporate the new fixes.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2025-5279?

3 open source packages ship an affected version, including redshift-connector.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redshift-connector` | PyPI | From 2.0.872 | 2.1.7 |
| `redshift-connector` | PyPI | From 2.0.872 | 2.1.7 |
| `redshift-connector` | PyPI | From 2.0.872 | 2.1.7 |

## How do I fix CVE-2025-5279?

Upgrade redshift-connector to 2.1.7 or later.

## Is CVE-2025-5279 being exploited?

There is no known exploitation of CVE-2025-5279 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5279 and fix it if it is affected.

What it is: CVE-2025-5279 is a high-severity vulnerability in Amazon Redshift, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-5279 in the wild and no public exploit code.

Affected packages and fixed versions:
- redshift-connector (PyPI): affected from 2.0.872; fixed in 2.1.7
- redshift-connector (PyPI): affected from 2.0.872; fixed in 2.1.7
- redshift-connector (PyPI): affected from 2.0.872; fixed in 2.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5279/ (Markdown: https://insights.sbomify.com/CVE-2025-5279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5279
- OSV: https://osv.dev/vulnerability/CVE-2025-5279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5279/
Summaries are generated and may contain mistakes; the official description above is the record.
