CVE-2025-52882 Claude Code IDE extensions allow websocket connections from arbitrary origins

High 8.8 Published Updated

Attackers can connect to the IDE extension via websockets to read files, view open documents, or execute code in specific scenarios.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-52882?

CVE-2025-52882 is a high-severity missing authorization vulnerability in anthropics claude-code, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Claude Code is an agentic coding tool. Claude Code extensions in VSCode and forks (e.g., Cursor, Windsurf, and VSCodium) and JetBrains IDEs (e.g., IntelliJ, Pycharm, and Android Studio) are vulnerable to unauthorized websocket connections from an attacker when visiting attacker-controlled webpages. Claude Code for VSCode IDE extensions versions 0.2.116 through 1.0.23 are vulnerable. For Jetbrains IDE plugins, Claude Code [beta] versions 0.1.1 through 0.1.8 are vulnerable. In VSCode (and forks), exploitation would allow an attacker to read arbitrary files, see the list of files open in the IDE, get selection and diagnostics events from the IDE, or execute code in limited situations where a user has an open Jupyter Notebook and accepts a malicious prompt. In JetBrains IDEs, an attacker could get selection events, a list of open files, and a list of syntax errors. Claude released a patch for this issue on June 13th, 2025. Although Claude Code auto-updates when a user launch it and auto-updates the extensions, users should take the following steps, though the exact steps depend on one's integrated development environment (IDE). For VSCode, Cursor, Windsurf, VSCodium, and other VSCode forks, check the extension Claude Code for VSCode. Open the list of Extensions (View->Extensions), look for Claude Code for VSCode among installed extensions, update or uninstall any version prior to 1.0.24, and restart the IDE. For JetBrains IDEs including IntelliJ, PyCharm, and Android Studio, check the plugin Claude Code [Beta]. Open the Plugins list, look for Claude Code [Beta] among installed extensions, update or uninstall any version prior to 0.1.9, and restart the IDE.

Weakness: CWE-1385

Which versions are affected by CVE-2025-52882?

2 open source packages ship an affected version, including @anthropic-ai/claude-code.

PackageAffectedFixed in
@anthropic-ai/claude-code npmFrom 0.2.1161.0.24
@anthropic-ai/claude-code npmFrom 0.2.1161.0.24

How do I fix CVE-2025-52882?

Upgrade @anthropic-ai/claude-code to 1.0.24 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-52882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52882 exists.

Sources

Also known as GHSA-9f65-56v6-gxw7.

Is CVE-2025-52882 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free