# CVE-2025-52882: Claude Code IDE extensions allow websocket connections from arbitrary origins

> Attackers can connect to the IDE extension via websockets to read files, view open documents, or execute code in specific scenarios.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** GHSA-9f65-56v6-gxw7

## What is CVE-2025-52882?

CVE-2025-52882 is a high-severity missing authorization vulnerability in anthropics claude-code, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. Claude Code extensions in VSCode and forks (e.g., Cursor, Windsurf, and VSCodium) and JetBrains IDEs (e.g., IntelliJ, Pycharm, and Android Studio) are vulnerable to unauthorized websocket connections from an attacker when visiting attacker-controlled webpages. Claude Code for VSCode IDE extensions versions 0.2.116 through 1.0.23 are vulnerable. For Jetbrains IDE plugins, Claude Code [beta] versions 0.1.1 through 0.1.8 are vulnerable. In VSCode (and forks), exploitation would allow an attacker to read arbitrary files, see the list of files open in the IDE, get selection and diagnostics events from the IDE, or execute code in limited situations where a user has an open Jupyter Notebook and accepts a malicious prompt. In JetBrains IDEs, an attacker could get selection events, a list of open files, and a list of syntax errors. Claude released a patch for this issue on June 13th, 2025. Although Claude Code auto-updates when a user launch it and auto-updates the extensions, users should take the following steps, though the exact steps depend on one's integrated development environment (IDE). For VSCode, Cursor, Windsurf, VSCodium, and other VSCode forks, check the extension Claude Code for VSCode. Open the list of Extensions (View->Extensions), look for Claude Code for VSCode among installed extensions, update or uninstall any version prior to 1.0.24, and restart the IDE. For JetBrains IDEs including IntelliJ, PyCharm, and Android Studio, check the plugin Claude Code [Beta]. Open the Plugins list, look for Claude Code [Beta] among installed extensions, update or uninstall any version prior to 0.1.9, and restart the IDE.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2025-52882?

2 open source packages ship an affected version, including @anthropic-ai/claude-code.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | From 0.2.116 | 1.0.24 |
| `@anthropic-ai/claude-code` | npm | From 0.2.116 | 1.0.24 |

## How do I fix CVE-2025-52882?

Upgrade @anthropic-ai/claude-code to 1.0.24 or later.

## Is CVE-2025-52882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52882 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52882 and fix it if it is affected.

What it is: CVE-2025-52882 is a high-severity missing authorization vulnerability in anthropics claude-code, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52882 exists.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected from 0.2.116; fixed in 1.0.24
- @anthropic-ai/claude-code (npm): affected from 0.2.116; fixed in 1.0.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52882/ (Markdown: https://insights.sbomify.com/CVE-2025-52882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52882
- OSV: https://osv.dev/vulnerability/CVE-2025-52882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52882/
Summaries are generated and may contain mistakes; the official description above is the record.
