{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-52885 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-52885 is a medium-severity use after free vulnerability in poppler, published on 10 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-52885 and fix it if it is affected.\n\nWhat it is: CVE-2025-52885 is a medium-severity use after free vulnerability in poppler, published on 10 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-52885 in the wild and no public exploit code.\n\nAffected product: poppler. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52885/ (Markdown: https://insights.sbomify.com/CVE-2025-52885/index.md)","id":"CVE-2025-52885","markdown":"https://insights.sbomify.com/CVE-2025-52885/index.md","name":"CVE-2025-52885","record":{"aliases":["BELL-CVE-2025-52885","DEBIAN-CVE-2025-52885","ECHO-7d56-ab20-1ebd","JLSEC-2026-89","MGASA-2025-0251","SUSE-SU-2025:21132-1","UBUNTU-CVE-2025-52885","USN-7858-1","openSUSE-SU-2025:15648-1","openSUSE-SU-2025:20068-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PDF rendering library","requires_auth":"none","summary":"A use-after-free vulnerability in Poppler allows attackers to execute arbitrary code or cause denial of service via crafted PDF files.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Poppler ia a library for rendering PDF files, and examining or modifying their structure. A use-after-free (write) vulnerability has been detected in versions Poppler prior to 25.10.0 within the StructTreeRoot class. The issue arises from the use of raw pointers to elements of a `std::vector`, which can lead to dangling pointers when the vector is resized. The vulnerability stems from the way that refToParentMap stores references to `std::vector` elements using raw pointers. These pointers may become invalid when the vector is resized. This vulnerability is a common security problem involving the use of raw pointers to `std::vectors`. Internally, `std::vector `stores its elements in a dynamically allocated array. When the array reaches its capacity and a new element is added, the vector reallocates a larger block of memory and moves all the existing elements to the new location. At this point if any pointers to elements are stored before a resize occurs, they become dangling pointers once the reallocation happens. Version 25.10.0 contains a patch for the issue.","ecosystems":["SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server for SAP applications 16.0","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GHSL-2025-042: Poppler has Use-After-Free","id":"CVE-2025-52885","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"use_after_free","year":"2025"},"n_packages":8,"n_references":3,"next":{"headline":"Poppler Use After Free Vulnerability","id":"CVE-2025-52886"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["25.04.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/suse/poppler\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2025:21132-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["25.04.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt6","purl":"pkg:rpm/suse/poppler-qt6\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2025:21132-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["25.04.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/suse/poppler\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2025:21132-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["25.04.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt6","purl":"pkg:rpm/suse/poppler-qt6\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2025:21132-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["25.04.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/opensuse/poppler\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2025:20068-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["25.04.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt5","purl":"pkg:rpm/opensuse/poppler-qt5\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2025:20068-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["25.04.0-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt6","purl":"pkg:rpm/opensuse/poppler-qt6\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2025:20068-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["25.09.1-2.1"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/opensuse/poppler\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15648-1"}],"prev":{"headline":"risc0-ethereum-contracts allows invalid commitment with digest value of zero to be accepted by Steel.validateCommitment","id":"CVE-2025-52884"},"products":["poppler"],"published":"2025-10-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["poppler"]},"summary":"A use-after-free vulnerability in Poppler allows attackers to execute arbitrary code or cause denial of service via crafted PDF files.","url":"https://insights.sbomify.com/CVE-2025-52885/"}