CVE-2025-52889 Incus vulnerable to DoS through antispoofing nftables firewall rule bypass on bridge networks with ACLs
Attackers can bypass firewall filtering to exhaust DHCP pools, causing denial of service in Incus environments using bridge networks with ACLs.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-52889?
CVE-2025-52889 is a low-severity denial of service vulnerability in lxc incus, published on 25 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Incus is a system container and virtual machine manager. When using an ACL on a device connected to a bridge, Incus version 6.12 and 6.13 generates nftables rules for local services (DHCP, DNS...) that partially bypass security options `security.mac_filtering`, `security.ipv4_filtering` and `security.ipv6_filtering`. This can lead to DHCP pool exhaustion and opens the door for other attacks. A patch is available at commit 2516fb19ad8428454cb4edfe70c0a5f0dc1da214.
Weakness: CWE-770
Which versions are affected by CVE-2025-52889?
4 open source packages ship an affected version, including github.com/lxc/incus/v6 and github.com/lxc/incus.
| Package | Affected | Fixed in |
|---|---|---|
github.com/lxc/incus/v6 Go | All versions | 6.14.0 |
github.com/lxc/incus/v6 Go | All versions | 6.14.0 |
github.com/lxc/incus/v6 Go | From 6.12.0 | 6.14.0 |
github.com/lxc/incus Go | All versions | None |
How do I fix CVE-2025-52889?
Upgrade github.com/lxc/incus/v6 to 6.14.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-52889 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52889 exists.
Sources
Also known as GHSA-9q7c-qmhm-jv86, GO-2025-3781, UBUNTU-CVE-2025-52889.