CVE-2025-52890 Incus vulnerable to antispoofing nftables firewall rule bypass on bridge networks with ACLs
Attackers can bypass MAC and IP filtering on bridge networks with ACLs to perform ARP spoofing and impersonate other containers or VMs.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-52890?
CVE-2025-52890 is a high-severity vulnerability in lxc incus, published on 25 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Incus is a system container and virtual machine manager. When using an ACL on a device connected to a bridge, Incus versions 6.12 and 6.13generates nftables rules that partially bypass security options `security.mac_filtering`, `security.ipv4_filtering` and `security.ipv6_filtering`. This can lead to ARP spoofing on the bridge and to fully spoof another VM/container on the same bridge. Commit 254dfd2483ab8de39b47c2258b7f1cf0759231c8 contains a patch for the issue.
Weakness: CWE-863
Which versions are affected by CVE-2025-52890?
4 open source packages ship an affected version, including github.com/lxc/incus/v6 and github.com/lxc/incus.
| Package | Affected | Fixed in |
|---|---|---|
github.com/lxc/incus/v6 Go | From 6.12.0 | 6.14.0 |
github.com/lxc/incus/v6 Go | From 6.12.0 | 6.14.0 |
github.com/lxc/incus/v6 Go | From 6.12.0 | 6.14.0 |
github.com/lxc/incus Go | All versions | None |
How do I fix CVE-2025-52890?
Upgrade github.com/lxc/incus/v6 to 6.14.0 or later.
Is CVE-2025-52890 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52890 exists.
Sources
Also known as GHSA-p7fw-vjjm-2rwp, GO-2025-3782, UBUNTU-CVE-2025-52890.