# CVE-2025-52890: Incus vulnerable to antispoofing nftables firewall rule bypass on bridge networks with ACLs

> Attackers can bypass MAC and IP filtering on bridge networks with ACLs to perform ARP spoofing and impersonate other containers or VMs.

- **Severity:** High 8.1 (`CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2025
- **Updated:** 25 Jun 2025
- **Also known as:** GHSA-p7fw-vjjm-2rwp, GO-2025-3782, UBUNTU-CVE-2025-52890

## What is CVE-2025-52890?

CVE-2025-52890 is a high-severity vulnerability in lxc incus, published on 25 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. When using an ACL on a device connected to a bridge, Incus versions 6.12 and 6.13generates nftables rules that partially bypass security options `security.mac_filtering`, `security.ipv4_filtering` and `security.ipv6_filtering`. This can lead to ARP spoofing on the bridge and to fully spoof another VM/container on the same bridge. Commit 254dfd2483ab8de39b47c2258b7f1cf0759231c8 contains a patch for the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-52890?

4 open source packages ship an affected version, including github.com/lxc/incus/v6 and github.com/lxc/incus.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6` | Go | From 6.12.0 | 6.14.0 |
| `github.com/lxc/incus/v6` | Go | From 6.12.0 | 6.14.0 |
| `github.com/lxc/incus/v6` | Go | From 6.12.0 | 6.14.0 |
| `github.com/lxc/incus` | Go | All versions | None |

## How do I fix CVE-2025-52890?

Upgrade github.com/lxc/incus/v6 to 6.14.0 or later.

## Is CVE-2025-52890 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52890 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52890 and fix it if it is affected.

What it is: CVE-2025-52890 is a high-severity vulnerability in lxc incus, published on 25 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52890 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6 (Go): affected from 6.12.0; fixed in 6.14.0
- github.com/lxc/incus/v6 (Go): affected from 6.12.0; fixed in 6.14.0
- github.com/lxc/incus/v6 (Go): affected from 6.12.0; fixed in 6.14.0
- github.com/lxc/incus (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52890/ (Markdown: https://insights.sbomify.com/CVE-2025-52890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52890
- OSV: https://osv.dev/vulnerability/CVE-2025-52890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52890/
Summaries are generated and may contain mistakes; the official description above is the record.
