{"answers":{"affected":"2 open source packages ship an affected version, including modsecurity and modsecurity2.","exploited":"There is no known exploitation of CVE-2025-52891 in the wild and no public exploit code.","fix":"Upgrade modsecurity to 3.0.12 or later.","what":"CVE-2025-52891 is a medium-severity denial of service vulnerability in owasp-modsecurity ModSecurity, published on 2 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-52891 and fix it if it is affected.\n\nWhat it is: CVE-2025-52891 is a medium-severity denial of service vulnerability in owasp-modsecurity ModSecurity, published on 2 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-52891 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modsecurity (Bitnami): affected from 2.9.8; fixed in 3.0.12\n- modsecurity2 (Bitnami): affected from 2.9.8; fixed in 2.9.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52891/ (Markdown: https://insights.sbomify.com/CVE-2025-52891/index.md)","id":"CVE-2025-52891","markdown":"https://insights.sbomify.com/CVE-2025-52891/index.md","name":"CVE-2025-52891","record":{"aliases":["BIT-modsecurity-2025-52891","BIT-modsecurity2-2025-52891","DEBIAN-CVE-2025-52891","GHSA-gw9c-4wfm-vj3x","OESA-2025-1751","OESA-2025-1752","OESA-2025-1753","OESA-2025-1754","OESA-2025-1755","UBUNTU-CVE-2025-52891","openSUSE-SU-2025:15313-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Web Application Firewall","requires_auth":"none","summary":"An attacker can cause a segmentation fault and denial of service in ModSecurity by sending an empty XML tag when XML parsing is enabled.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.8 to before 2.9.11, an empty XML tag can cause a segmentation fault. If SecParseXmlIntoArgs is set to On or OnlyArgs, and the request type is application/xml, and at least one XML tag is empty (eg \u003cfoo\u003e\u003c/foo\u003e), then a segmentation fault occurs. This issue has been patched in version 2.9.11. A workaround involves setting SecParseXmlIntoArgs to Off.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ModSecurity empty XML tag causes segmentation fault","id":"CVE-2025-52891","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"EspoCRM is vulnerable to access denial through double slash in URI corrupting router cache","id":"CVE-2025-52892"},"packages":[{"ecosystem":"Bitnami","fixed":["3.0.12"],"introduced":["2.9.8"],"last_affected":[],"package":"modsecurity","purl":"pkg:bitnami/modsecurity","source":"BIT-modsecurity-2025-52891"},{"ecosystem":"Bitnami","fixed":["2.9.11"],"introduced":["2.9.8"],"last_affected":[],"package":"modsecurity2","purl":"pkg:bitnami/modsecurity2","source":"BIT-modsecurity2-2025-52891"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.9.11-1.1"],"introduced":["0"],"last_affected":[],"package":"apache2-mod_security2","purl":"pkg:rpm/opensuse/apache2-mod_security2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15313-1"}],"prev":{"headline":"Incus vulnerable to antispoofing nftables firewall rule bypass on bridge networks with ACLs","id":"CVE-2025-52890"},"products":["ModSecurity"],"published":"2025-07-02","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-02","vendors":["owasp-modsecurity"]},"summary":"An attacker can cause a segmentation fault and denial of service in ModSecurity by sending an empty XML tag when XML parsing is enabled.","url":"https://insights.sbomify.com/CVE-2025-52891/"}