{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-52892 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-52892 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-52892 is a medium-severity denial of service vulnerability in espocrm, published on 5 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-52892 and fix it if it is affected.\n\nWhat it is: CVE-2025-52892 is a medium-severity denial of service vulnerability in espocrm, published on 5 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-52892 in the wild and no public exploit code.\n\nAffected product: espocrm. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52892/ (Markdown: https://insights.sbomify.com/CVE-2025-52892/index.md)","id":"CVE-2025-52892","markdown":"https://insights.sbomify.com/CVE-2025-52892/index.md","name":"CVE-2025-52892","record":{"aliases":["GHSA-26x2-6wch-j8pf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"EspoCRM","requires_auth":"high_privilege","summary":"Attackers can cause a denial of service in EspoCRM by sending requests with double slashes, corrupting the router cache and rendering the instance unusable.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"espocrm","vendor":"espocrm"}],"cvss":{"score":4.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"EspoCRM is a web application with a frontend designed as a single-page application and a REST API backend written in PHP. In versions 9.1.6 and below, if a user loads Espo in the browser with double slashes (e.g https://domain//#Admin) and the webserver does not strip the double slash, it can cause a corrupted Slim router's cache. This will make the instance unusable until there is a completed rebuild. This is fixed in version 9.1.7.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"EspoCRM is vulnerable to access denial through double slash in URI corrupting router cache","id":"CVE-2025-52892","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"OpenBao May Leak Sensitive Information in Logs When Processing Malformed Data","id":"CVE-2025-52893"},"packages":[],"prev":{"headline":"ModSecurity empty XML tag causes segmentation fault","id":"CVE-2025-52891"},"products":["espocrm"],"published":"2025-08-05","related":[{"cvss_score":10,"headline":"Path traversal in n/a","id":"CVE-2014-7985","kev_date_added":null,"published":"2014-10-31"},{"cvss_score":9.1,"headline":"Path traversal in espocrm","id":"CVE-2026-33656","kev_date_added":null,"published":"2026-04-22"},{"cvss_score":8.8,"headline":"File upload in n/a","id":"CVE-2022-38843","kev_date_added":null,"published":"2022-09-16"},{"cvss_score":8.8,"headline":"Information disclosure in n/a","id":"CVE-2019-14351","kev_date_added":null,"published":"2019-07-28"},{"cvss_score":8.6,"headline":"EspoCRM 5.7.0 \u003c 5.9.0 - Two-Factor Authentication Bypass via Auth Token Reuse Between Accounts with Identical Passwords","id":"CVE-2020-37094","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8,"headline":"Code injection in n/a","id":"CVE-2022-38844","kev_date_added":null,"published":"2022-09-16"},{"cvss_score":7.2,"headline":"EspoCRM has Admin TemplateManager path traversal that allows arbitrary file read write and delete","id":"CVE-2026-33733","kev_date_added":null,"published":"2026-04-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-05","vendors":["espocrm"]},"summary":"Attackers can cause a denial of service in EspoCRM by sending requests with double slashes, corrupting the router cache and rendering the instance unusable.","url":"https://insights.sbomify.com/CVE-2025-52892/"}