# CVE-2025-52892: EspoCRM is vulnerable to access denial through double slash in URI corrupting router cache

> Attackers can cause a denial of service in EspoCRM by sending requests with double slashes, corrupting the router cache and rendering the instance unusable.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-26x2-6wch-j8pf

## What is CVE-2025-52892?

CVE-2025-52892 is a medium-severity denial of service vulnerability in espocrm, published on 5 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

EspoCRM is a web application with a frontend designed as a single-page application and a REST API backend written in PHP. In versions 9.1.6 and below, if a user loads Espo in the browser with double slashes (e.g https://domain//#Admin) and the webserver does not strip the double slash, it can cause a corrupted Slim router's cache. This will make the instance unusable until there is a completed rebuild. This is fixed in version 9.1.7.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-52892?

It affects 1 product.


Products: Espocrm Espocrm.

## How do I fix CVE-2025-52892?

No fix has been published for CVE-2025-52892 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-52892 being exploited?

There is no known exploitation of CVE-2025-52892 in the wild and no public exploit code.

## Other vulnerabilities in espocrm

- [CVE-2014-7985](https://insights.sbomify.com/CVE-2014-7985/): Path traversal in n/a (critical 10.0)
- [CVE-2026-33656](https://insights.sbomify.com/CVE-2026-33656/): Path traversal in espocrm (critical 9.1)
- [CVE-2022-38843](https://insights.sbomify.com/CVE-2022-38843/): File upload in n/a (high 8.8)
- [CVE-2019-14351](https://insights.sbomify.com/CVE-2019-14351/): Information disclosure in n/a (high 8.8)
- [CVE-2020-37094](https://insights.sbomify.com/CVE-2020-37094/): EspoCRM 5.7.0 < 5.9.0 - Two-Factor Authentication Bypass via Auth Token Reuse Between Accounts with Identical Passwords (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52892 and fix it if it is affected.

What it is: CVE-2025-52892 is a medium-severity denial of service vulnerability in espocrm, published on 5 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-52892 in the wild and no public exploit code.

Affected product: espocrm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52892/ (Markdown: https://insights.sbomify.com/CVE-2025-52892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52892
- OSV: https://osv.dev/vulnerability/CVE-2025-52892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52892/
Summaries are generated and may contain mistakes; the official description above is the record.
