# CVE-2025-52894: OpenBao Vulnerable to Unauthenticated Rekey Operation Cancellation

> Unauthenticated attackers can cancel root and recovery rekey operations in OpenBao, causing a denial of service.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2025
- **Updated:** 25 Jun 2025
- **Also known as:** BIT-openbao-2025-52894, CLEANSTART-2026-LK31103, GHSA-prpj-rchp-9j5h, GO-2025-3783

## What is CVE-2025-52894?

CVE-2025-52894 is a medium-severity missing authorization vulnerability in openbao, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. OpenBao before v2.3.0 allowed an attacker to perform unauthenticated, unaudited cancellation of root rekey and recovery rekey operations, effecting a denial of service. In OpenBao v2.2.0 and later, manually setting the configuration option `disable_unauthed_rekey_endpoints=true` allows an operator to deny these rarely-used endpoints on global listeners. A patch is available at commit fe75468822a22a88318c6079425357a02ae5b77b. In a future OpenBao release communicated on OpenBao's website, the maintainers will set this to `true` for all users and provide an authenticated alternative. As a workaround, if an active proxy or load balancer sits in front of OpenBao, an operator can deny requests to these endpoints from unauthorized IP ranges.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-52894?

6 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | None |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250625150133-fe75468822a2 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250625150133-fe75468822a2 |
| `github.com/openbao/openbao` | Go | From 0.1.0 | None |
| `github.com/openbao/openbao` | Go | From 0.1.0 | None |
| `openbao` | Bitnami | From 2.2.2 | 2.3.1 |

Products: Openbao Openbao.

## How do I fix CVE-2025-52894?

Upgrade github.com/openbao/openbao to 0.0.0-20250625150133-fe75468822a2 or later.

## Is CVE-2025-52894 being exploited?

There is no known exploitation of CVE-2025-52894 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52894 and fix it if it is affected.

What it is: CVE-2025-52894 is a medium-severity missing authorization vulnerability in openbao, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52894 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; no fix listed
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250625150133-fe75468822a2
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250625150133-fe75468822a2
- github.com/openbao/openbao (Go): affected from 0.1.0; no fix listed
- github.com/openbao/openbao (Go): affected from 0.1.0; no fix listed
- openbao (Bitnami): affected from 2.2.2; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52894/ (Markdown: https://insights.sbomify.com/CVE-2025-52894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52894
- OSV: https://osv.dev/vulnerability/CVE-2025-52894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52894/
Summaries are generated and may contain mistakes; the official description above is the record.
