CVE-2025-52895 Frappe possibility of SQL injection due to improper validations

High 8.7 Published Updated

Attackers can execute SQL injection via crafted requests to access sensitive data in Frappe applications, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-52895?

CVE-2025-52895 is a high-severity SQL injection vulnerability in frappe, published on 30 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Frappe is a full-stack web application framework. Prior to versions 14.94.3 and 15.58.0, SQL injection could be achieved via a specially crafted request, which could allow malicious person to gain access to sensitive information. This issue has been patched in versions 14.94.3 and 15.58.0. There are no workarounds for this issue other than upgrading.

Weakness: CWE-89

Which versions are affected by CVE-2025-52895?

It affects 1 product.

Products include Frappe Frappe.

How do I fix CVE-2025-52895?

No fix has been published for CVE-2025-52895 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-52895 being exploited?

There is no known exploitation of CVE-2025-52895 in the wild and no public exploit code.

Sources

Also known as GHSA-mhj8-jfhf-mcw9.

Is CVE-2025-52895 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free