CVE-2025-52896 Frappe authenticated XSS via data import

High 8.6 Published Updated

Authenticated attackers can execute arbitrary scripts via malicious file uploads in Frappe Data Import, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-52896?

CVE-2025-52896 is a high-severity cross-site scripting vulnerability in frappe, published on 30 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Frappe is a full-stack web application framework. Prior to versions 14.94.2 and 15.57.0, authenticated users could upload carefully crafted malicious files via Data Import, leading to cross-site scripting (XSS). This issue has been patched in versions 14.94.2 and 15.57.0. There are no workarounds for this issue other than upgrading.

Weakness: CWE-79

Which versions are affected by CVE-2025-52896?

It affects 1 product.

Products include Frappe Frappe.

How do I fix CVE-2025-52896?

No fix has been published for CVE-2025-52896 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-52896 being exploited?

There is no known exploitation of CVE-2025-52896 in the wild and no public exploit code.

Sources

Also known as GHSA-hv29-66qg-2v6p.

Is CVE-2025-52896 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free