{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-52896 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-52896 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-52896 is a high-severity cross-site scripting vulnerability in frappe, published on 30 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-52896 and fix it if it is affected.\n\nWhat it is: CVE-2025-52896 is a high-severity cross-site scripting vulnerability in frappe, published on 30 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-52896 in the wild and no public exploit code.\n\nAffected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52896/ (Markdown: https://insights.sbomify.com/CVE-2025-52896/index.md)","id":"CVE-2025-52896","markdown":"https://insights.sbomify.com/CVE-2025-52896/index.md","name":"CVE-2025-52896","record":{"aliases":["GHSA-hv29-66qg-2v6p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Frappe web framework","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary scripts via malicious file uploads in Frappe Data Import, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"frappe","vendor":"frappe"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Frappe is a full-stack web application framework. Prior to versions 14.94.2 and 15.57.0, authenticated users could upload carefully crafted malicious files via Data Import, leading to cross-site scripting (XSS). This issue has been patched in versions 14.94.2 and 15.57.0. There are no workarounds for this issue other than upgrading.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Frappe authenticated XSS via data import","id":"CVE-2025-52896","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":4,"next":{"headline":"GLPI is vulnerable to XSS and open redirection attacks through planning feature","id":"CVE-2025-52897"},"packages":[],"prev":{"headline":"Frappe possibility of SQL injection due to improper validations","id":"CVE-2025-52895"},"products":["frappe"],"published":"2025-06-30","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-14965","kev_date_added":null,"published":"2019-08-12"},{"cvss_score":9.3,"headline":"Frappe has a SQL injection in bulk_update","id":"CVE-2026-35614","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":9.3,"headline":"Frappe SQL Injection due to improper field sanitization","id":"CVE-2026-31877","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":9.1,"headline":"Frappe may be vulnerable remote code execution due to server-side template injection","id":"CVE-2025-68929","kev_date_added":null,"published":"2025-12-29"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2019-14966","kev_date_added":null,"published":"2019-08-12"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2017-1000120","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":8.7,"headline":"Frappe has the possibility of SQL Injection due to improper validations","id":"CVE-2025-55732","kev_date_added":null,"published":"2025-08-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-30","vendors":["frappe"]},"summary":"Authenticated attackers can execute arbitrary scripts via malicious file uploads in Frappe Data Import, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2025-52896/"}