CVE-2025-52897 GLPI is vulnerable to XSS and open redirection attacks through planning feature
Unauthenticated attackers can exploit XSS and open redirection in the planning feature to conduct phishing attacks against GLPI users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-52897?
CVE-2025-52897 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
GLPI is a Free Asset and IT Management Software package. In versions 9.1.0 through 10.0.18, an unauthenticated user can send a malicious link to attempt a phishing attack from the planning feature. This is fixed in version 10.0.19.
Which versions are affected by CVE-2025-52897?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2025-52897?
No fix has been published for CVE-2025-52897 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-52897 being exploited?
There is no known exploitation of CVE-2025-52897 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-6whm-q2rp-prqm, UBUNTU-CVE-2025-52897.