# CVE-2025-52897: GLPI is vulnerable to XSS and open redirection attacks through planning feature

> Unauthenticated attackers can exploit XSS and open redirection in the planning feature to conduct phishing attacks against GLPI users.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 30 Jul 2025
- **Updated:** 30 Jul 2025
- **Also known as:** GHSA-6whm-q2rp-prqm, UBUNTU-CVE-2025-52897

## What is CVE-2025-52897?

CVE-2025-52897 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

GLPI is a Free Asset and IT Management Software package. In versions 9.1.0 through 10.0.18, an unauthenticated user can send a malicious link to attempt a phishing attack from the planning feature. This is fixed in version 10.0.19.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-52897?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2025-52897?

No fix has been published for CVE-2025-52897 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-52897 being exploited?

There is no known exploitation of CVE-2025-52897 in the wild and no public exploit code.

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52897 and fix it if it is affected.

What it is: CVE-2025-52897 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 30 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-52897 in the wild and no public exploit code.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52897/ (Markdown: https://insights.sbomify.com/CVE-2025-52897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52897
- OSV: https://osv.dev/vulnerability/CVE-2025-52897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52897/
Summaries are generated and may contain mistakes; the official description above is the record.
