# CVE-2025-52904: File Browser: Command Execution not Limited to Scope

> Attackers can execute arbitrary shell commands outside their assigned scope if command execution is enabled, requiring administrators to disable this feature.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2025
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-hc8f-m8g5-8362, GO-2025-3793

## What is CVE-2025-52904?

CVE-2025-52904 is a high-severity command injection vulnerability in filebrowser, published on 26 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

File Browser provides a file managing interface within a specified directory and it can be used to upload, delete, preview, rename and edit files. In versions of the web application on the 2.x branch, all users have a scope assigned, and they only have access to the files within that scope. The Command Execution feature of Filebrowser allows the execution of shell commands which are not restricted to the scope, potentially giving an attacker read and write access to all files managed by the server. Until this issue is fixed, the maintainers recommend to completely disable `Execute commands` for all accounts. Since the command execution is an inherently dangerous feature that is not used by all deployments, it should be possible to completely disable it in the application's configuration. This feature has been disabled by default for all installations from v2.33.8 onwards, including for existent installations. To exploit this vulnerability, the instance administrator must turn on a feature and ignore all the warnings about known vulnerabilities.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-52904?

4 open source packages ship an affected version, including github.com/filebrowser/filebrowser/v2 and github.com/filebrowser/filebrowser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/filebrowser/filebrowser/v2` | Go | All versions | None |
| `github.com/filebrowser/filebrowser/v2` | Go | All versions | 2.33.8 |
| `github.com/filebrowser/filebrowser/v2` | Go | All versions | 2.33.8 |
| `github.com/filebrowser/filebrowser` | Go | All versions | None |

Products: Filebrowser Filebrowser.

## How do I fix CVE-2025-52904?

Upgrade github.com/filebrowser/filebrowser/v2 to 2.33.8 or later.

## Is CVE-2025-52904 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52904 exists.

## Other vulnerabilities in filebrowser

- [CVE-2026-32760](https://insights.sbomify.com/CVE-2026-32760/): File Browser Self Registration Grants Any User Admin Access When Default Permissions Include Admin (critical 10.0)
- [CVE-2026-29188](https://insights.sbomify.com/CVE-2026-29188/): File Browser: TUS Delete Endpoint Bypasses Delete Permission Check (critical 9.1)
- [CVE-2023-39612](https://insights.sbomify.com/CVE-2023-39612/): Cross-site scripting in n/a (critical 9.0)
- [CVE-2026-30934](https://insights.sbomify.com/CVE-2026-30934/): FileBrowser Quantum: Stored XSS in public share page via unsanitized share metadata (text/template misuse) (high 8.9)
- [CVE-2021-46398](https://insights.sbomify.com/CVE-2021-46398/): Cross-Site Request Forgery in Filebrowser (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52904 and fix it if it is affected.

What it is: CVE-2025-52904 is a high-severity command injection vulnerability in filebrowser, published on 26 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52904 exists.

Affected packages and fixed versions:
- github.com/filebrowser/filebrowser/v2 (Go): affected all versions; no fix listed
- github.com/filebrowser/filebrowser/v2 (Go): affected all versions; fixed in 2.33.8
- github.com/filebrowser/filebrowser/v2 (Go): affected all versions; fixed in 2.33.8
- github.com/filebrowser/filebrowser (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52904/ (Markdown: https://insights.sbomify.com/CVE-2025-52904/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52904
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52904
- OSV: https://osv.dev/vulnerability/CVE-2025-52904

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52904/
Summaries are generated and may contain mistakes; the official description above is the record.
