{"answers":{"affected":"6 open source packages ship an affected version, including mlflow.","exploited":"There is no known exploitation of CVE-2025-52967 in the wild and no public exploit code.","fix":"Upgrade mlflow to a fixed version for your release line: 3.1.0 or 2.22.2.","what":"CVE-2025-52967 is a medium-severity server-side request forgery vulnerability in lfprojects MLflow, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-52967 and fix it if it is affected.\n\nWhat it is: CVE-2025-52967 is a medium-severity server-side request forgery vulnerability in lfprojects MLflow, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-52967 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mlflow (Bitnami): affected all versions; fixed in 3.1.0\n- mlflow (PyPI): affected all versions; fixed in 2.22.2\n- mlflow (PyPI): affected all versions; fixed in 2.22.2\n- mlflow (PyPI): affected all versions; fixed in 3.1.0\n- mlflow (PyPI): affected from 3.0.0rc0; fixed in 3.1.0\n- mlflow (PyPI): affected from 3.0.0rc0; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-52967/ (Markdown: https://insights.sbomify.com/CVE-2025-52967/index.md)","id":"CVE-2025-52967","markdown":"https://insights.sbomify.com/CVE-2025-52967/index.md","name":"CVE-2025-52967","record":{"aliases":["BIT-mlflow-2025-52967","GHSA-wxj7-3fx5-pp9m","PYSEC-2025-52"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"MLflow library","requires_auth":"none","summary":"Attackers can exploit missing gateway path validation in MLflow to perform Server-Side Request Forgery, potentially accessing internal resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"gateway_proxy_handler in MLflow before 3.1.0 lacks gateway_path validation.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MLFlow SSRF via gateway_proxy_handler","id":"CVE-2025-52967","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":6,"n_references":3,"next":{"headline":"Cross-site request forgery in xdg-utils","id":"CVE-2025-52968"},"packages":[{"ecosystem":"Bitnami","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"mlflow","purl":"pkg:bitnami/mlflow","source":"BIT-mlflow-2025-52967"},{"ecosystem":"PyPI","fixed":["2.22.2"],"introduced":["0"],"last_affected":[],"package":"mlflow","purl":null,"source":"GHSA-wxj7-3fx5-pp9m"},{"ecosystem":"PyPI","fixed":["2.22.2"],"introduced":["0"],"last_affected":[],"package":"mlflow","purl":"pkg:pypi/mlflow","source":"GHSA-wxj7-3fx5-pp9m"},{"ecosystem":"PyPI","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"mlflow","purl":"pkg:pypi/mlflow","source":"PYSEC-2025-52"},{"ecosystem":"PyPI","fixed":["3.1.0"],"introduced":["3.0.0rc0"],"last_affected":[],"package":"mlflow","purl":null,"source":"GHSA-wxj7-3fx5-pp9m"},{"ecosystem":"PyPI","fixed":["3.1.0"],"introduced":["3.0.0rc0"],"last_affected":[],"package":"mlflow","purl":"pkg:pypi/mlflow","source":"GHSA-wxj7-3fx5-pp9m"}],"prev":{"headline":"Denial of service in Junos OS","id":"CVE-2025-52964"},"products":["MLflow"],"published":"2025-06-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-23","vendors":["lfprojects"]},"summary":"Attackers can exploit missing gateway path validation in MLflow to perform Server-Side Request Forgery, potentially accessing internal resources.","url":"https://insights.sbomify.com/CVE-2025-52967/"}