# CVE-2025-52967: MLFlow SSRF via gateway_proxy_handler

> Attackers can exploit missing gateway path validation in MLflow to perform Server-Side Request Forgery, potentially accessing internal resources.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** BIT-mlflow-2025-52967, GHSA-wxj7-3fx5-pp9m, PYSEC-2025-52

## What is CVE-2025-52967?

CVE-2025-52967 is a medium-severity server-side request forgery vulnerability in lfprojects MLflow, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

gateway_proxy_handler in MLflow before 3.1.0 lacks gateway_path validation.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-52967?

6 open source packages ship an affected version, including mlflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.1.0 |
| `mlflow` | PyPI | All versions | 2.22.2 |
| `mlflow` | PyPI | All versions | 2.22.2 |
| `mlflow` | PyPI | All versions | 3.1.0 |
| `mlflow` | PyPI | From 3.0.0rc0 | 3.1.0 |
| `mlflow` | PyPI | From 3.0.0rc0 | 3.1.0 |

## How do I fix CVE-2025-52967?

Upgrade mlflow to a fixed version for your release line: 3.1.0 or 2.22.2.

## Is CVE-2025-52967 being exploited?

There is no known exploitation of CVE-2025-52967 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52967 and fix it if it is affected.

What it is: CVE-2025-52967 is a medium-severity server-side request forgery vulnerability in lfprojects MLflow, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52967 in the wild and no public exploit code.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.1.0
- mlflow (PyPI): affected all versions; fixed in 2.22.2
- mlflow (PyPI): affected all versions; fixed in 2.22.2
- mlflow (PyPI): affected all versions; fixed in 3.1.0
- mlflow (PyPI): affected from 3.0.0rc0; fixed in 3.1.0
- mlflow (PyPI): affected from 3.0.0rc0; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52967/ (Markdown: https://insights.sbomify.com/CVE-2025-52967/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52967
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52967
- OSV: https://osv.dev/vulnerability/CVE-2025-52967

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52967/
Summaries are generated and may contain mistakes; the official description above is the record.
