# CVE-2025-52994: phpThumb is vulnerable to Command Injection through its gif_outputAsJpeg function

> Attackers can execute arbitrary OS commands via crafted parameters in phpThumb, requiring immediate patching for all users.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Jul 2025
- **Updated:** 11 Jul 2025
- **Also known as:** GHSA-q745-cfqh-hcrw

## What is CVE-2025-52994?

CVE-2025-52994 is a medium-severity command injection vulnerability in phpThumb, published on 11 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

gif_outputAsJpeg in phpThumb through 1.7.23 allows phpthumb.gif.php OS Command Injection via a crafted parameter value. This is fixed in 1.7.23-202506081709.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-52994?

2 open source packages ship an affected version, including james-heinrich/phpthumb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `james-heinrich/phpthumb` | Packagist | All versions to 1.7.23 | None |
| `james-heinrich/phpthumb` | Packagist | All versions to 1.7.23 | None |

## How do I fix CVE-2025-52994?

No fix has been published for CVE-2025-52994 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-52994 being exploited?

There is no known exploitation of CVE-2025-52994 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52994 and fix it if it is affected.

What it is: CVE-2025-52994 is a medium-severity command injection vulnerability in phpThumb, published on 11 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-52994 in the wild and no public exploit code.

Affected packages and fixed versions:
- james-heinrich/phpthumb (Packagist): affected all versions up to 1.7.23; no fix listed
- james-heinrich/phpthumb (Packagist): affected all versions up to 1.7.23; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52994/ (Markdown: https://insights.sbomify.com/CVE-2025-52994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52994
- OSV: https://osv.dev/vulnerability/CVE-2025-52994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52994/
Summaries are generated and may contain mistakes; the official description above is the record.
