# CVE-2025-52997: File Browser Insecurely Handles Passwords

> Attackers can brute-force user passwords due to missing rate limiting and weak password policies, leading to account takeover.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2025
- **Updated:** 4 Aug 2025
- **Also known as:** GHSA-cm2r-rg7r-p7gg, GO-2025-3792

## What is CVE-2025-52997?

CVE-2025-52997 is a medium-severity authentication bypass vulnerability in filebrowser, published on 30 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

File Browser provides a file managing interface within a specified directory and it can be used to upload, delete, preview, rename and edit files. Prior to version 2.34.1, a missing password policy and brute-force protection makes the authentication process insecure. Attackers could mount a brute-force attack to retrieve the passwords of all accounts in a given instance. This issue has been patched in version 2.34.1.

Weakness: CWE-521 (Weak Password Requirements), CWE-307 (Improper Restriction of Excessive Authentication Attempts), CWE-1392 (Use of Default Credentials)

## Which versions are affected by CVE-2025-52997?

6 open source packages ship an affected version, including github.com/filebrowser/filebrowser and github.com/filebrowser/filebrowser/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/filebrowser/filebrowser` | Go | All versions | None |
| `github.com/filebrowser/filebrowser` | Go | All versions to 1.11.0 | None |
| `github.com/filebrowser/filebrowser` | Go | All versions to 1.11.0 | None |
| `github.com/filebrowser/filebrowser/v2` | Go | All versions | 2.34.1 |
| `github.com/filebrowser/filebrowser/v2` | Go | All versions | 2.34.1 |
| `github.com/filebrowser/filebrowser/v2` | Go | All versions | 2.34.1 |

Products: Filebrowser Filebrowser.

## How do I fix CVE-2025-52997?

Upgrade to a fixed version.

## Is CVE-2025-52997 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52997 exists.

## Other vulnerabilities in filebrowser

- [CVE-2026-32760](https://insights.sbomify.com/CVE-2026-32760/): File Browser Self Registration Grants Any User Admin Access When Default Permissions Include Admin (critical 10.0)
- [CVE-2026-29188](https://insights.sbomify.com/CVE-2026-29188/): File Browser: TUS Delete Endpoint Bypasses Delete Permission Check (critical 9.1)
- [CVE-2023-39612](https://insights.sbomify.com/CVE-2023-39612/): Cross-site scripting in n/a (critical 9.0)
- [CVE-2026-30934](https://insights.sbomify.com/CVE-2026-30934/): FileBrowser Quantum: Stored XSS in public share page via unsanitized share metadata (text/template misuse) (high 8.9)
- [CVE-2021-46398](https://insights.sbomify.com/CVE-2021-46398/): Cross-Site Request Forgery in Filebrowser (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-52997 and fix it if it is affected.

What it is: CVE-2025-52997 is a medium-severity authentication bypass vulnerability in filebrowser, published on 30 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-52997 exists.

Affected packages and fixed versions:
- github.com/filebrowser/filebrowser (Go): affected all versions; no fix listed
- github.com/filebrowser/filebrowser (Go): affected all versions up to 1.11.0; no fix listed
- github.com/filebrowser/filebrowser (Go): affected all versions up to 1.11.0; no fix listed
- github.com/filebrowser/filebrowser/v2 (Go): affected all versions; fixed in 2.34.1
- github.com/filebrowser/filebrowser/v2 (Go): affected all versions; fixed in 2.34.1
- github.com/filebrowser/filebrowser/v2 (Go): affected all versions; fixed in 2.34.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-52997/ (Markdown: https://insights.sbomify.com/CVE-2025-52997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-52997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-52997
- OSV: https://osv.dev/vulnerability/CVE-2025-52997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-52997/
Summaries are generated and may contain mistakes; the official description above is the record.
