{"answers":{"affected":"2 open source packages ship an affected version, including io.jans:jans-config-api-server.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53003 exists.","fix":"Upgrade io.jans:jans-config-api-server to 1.8.0 or later.","what":"CVE-2025-53003 is a high-severity missing authorization vulnerability in JanssenProject jans, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53003 and fix it if it is affected.\n\nWhat it is: CVE-2025-53003 is a high-severity missing authorization vulnerability in JanssenProject jans, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53003 exists.\n\nAffected packages and fixed versions:\n- io.jans:jans-config-api-server (Maven): affected all versions; fixed in 1.8.0\n- io.jans:jans-config-api-server (Maven): affected all versions; fixed in 1.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53003/ (Markdown: https://insights.sbomify.com/CVE-2025-53003/index.md)","id":"CVE-2025-53003","markdown":"https://insights.sbomify.com/CVE-2025-53003/index.md","name":"CVE-2025-53003","record":{"aliases":["GHSA-373j-mhpf-84wg"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Identity and Access Management","requires_auth":"none","summary":"Attackers can access sensitive identity provider configuration data without proper scope verification, exposing clients and users.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"},{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The Janssen Project is an open-source identity and access management (IAM) platform. Prior to version 1.8.0, the Config API returns results without scope verification. This has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc. This issue has been patched in version 1.8.0. A workaround for this vulnerability involves users forking and building the config api, patching it in their system following commit 92eea4d.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Janssen Config API returns results without scope verification","id":"CVE-2025-53003","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Dataease Redshift Data Source JDBC Connection Parameters Bypass Vulnerability","id":"CVE-2025-53004"},"packages":[{"ecosystem":"Maven","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"io.jans:jans-config-api-server","purl":null,"source":"GHSA-373j-mhpf-84wg"},{"ecosystem":"Maven","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"io.jans:jans-config-api-server","purl":"pkg:maven/io.jans/jans-config-api-server","source":"GHSA-373j-mhpf-84wg"}],"prev":{"headline":"LLaMA-Factory Remote Code Execution (RCE) Vulnerability","id":"CVE-2025-53002"},"products":["jans"],"published":"2025-07-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-01","vendors":["JanssenProject"]},"summary":"Attackers can access sensitive identity provider configuration data without proper scope verification, exposing clients and users.","url":"https://insights.sbomify.com/CVE-2025-53003/"}