# CVE-2025-53003: Janssen Config API returns results without scope verification

> Attackers can access sensitive identity provider configuration data without proper scope verification, exposing clients and users.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2025
- **Updated:** 1 Jul 2025
- **Also known as:** GHSA-373j-mhpf-84wg

## What is CVE-2025-53003?

CVE-2025-53003 is a high-severity missing authorization vulnerability in JanssenProject jans, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Janssen Project is an open-source identity and access management (IAM) platform. Prior to version 1.8.0, the Config API returns results without scope verification. This has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc. This issue has been patched in version 1.8.0. A workaround for this vulnerability involves users forking and building the config api, patching it in their system following commit 92eea4d.

Weakness: CWE-284 (Improper Access Control), CWE-269 (Improper Privilege Management), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-53003?

2 open source packages ship an affected version, including io.jans:jans-config-api-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jans:jans-config-api-server` | Maven | All versions | 1.8.0 |
| `io.jans:jans-config-api-server` | Maven | All versions | 1.8.0 |

## How do I fix CVE-2025-53003?

Upgrade io.jans:jans-config-api-server to 1.8.0 or later.

## Is CVE-2025-53003 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53003 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53003 and fix it if it is affected.

What it is: CVE-2025-53003 is a high-severity missing authorization vulnerability in JanssenProject jans, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53003 exists.

Affected packages and fixed versions:
- io.jans:jans-config-api-server (Maven): affected all versions; fixed in 1.8.0
- io.jans:jans-config-api-server (Maven): affected all versions; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53003/ (Markdown: https://insights.sbomify.com/CVE-2025-53003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53003
- OSV: https://osv.dev/vulnerability/CVE-2025-53003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53003/
Summaries are generated and may contain mistakes; the official description above is the record.
