# CVE-2025-53009: MaterialX Stack Overflow via Lack of MTLX XML Parsing Recursion Limit

> An attacker can crash applications using MaterialX by sending a malicious MTLX file with deeply nested nodegraphs, causing stack exhaustion.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2025
- **Updated:** 1 Aug 2025
- **Also known as:** GHSA-wx6g-fm6f-w822, PYSEC-2026-1609

## What is CVE-2025-53009?

CVE-2025-53009 is a medium-severity denial of service vulnerability in AcademySoftwareFoundation MaterialX, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MaterialX is an open standard for the exchange of rich material and look-development content across applications and renderers. In versions 1.39.2 and below, when parsing an MTLX file with multiple nested nodegraph implementations, the MaterialX XML parsing logic can potentially crash due to stack exhaustion. An attacker could intentionally crash a target program that uses OpenEXR by sending a malicious MTLX file. This is fixed in version 1.39.3.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-53009?

3 open source packages ship an affected version, including materialx and MaterialX. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `materialx` | PyPI | From 1.39.2 | 1.39.3 |
| `materialx` | PyPI | From 1.39.2 | 1.39.3 |
| `MaterialX` | PyPI | From 1.39.2 | 1.39.3 |

Products: Linuxfoundation Materialx.

## How do I fix CVE-2025-53009?

Upgrade materialx to 1.39.3 or later.

## Is CVE-2025-53009 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53009 exists.

## Other vulnerabilities in AcademySoftwareFoundation MaterialX

- [CVE-2025-53012](https://insights.sbomify.com/CVE-2025-53012/): MaterialX's Lack of Import Depth Limit Leads to DoS (Denial-Of-Service) Via Stack Exhaustion (medium 5.5)
- [CVE-2025-53010](https://insights.sbomify.com/CVE-2025-53010/): MaterialX's unchecked nodeGraph->getOutput return is vulnerable to NULL Pointer Dereference (low 2.0)
- [CVE-2025-53011](https://insights.sbomify.com/CVE-2025-53011/): MaterialX is Vulnerable to NULL Pointer Dereference due to Unchecked implGraphOutput (low 2.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53009 and fix it if it is affected.

What it is: CVE-2025-53009 is a medium-severity denial of service vulnerability in AcademySoftwareFoundation MaterialX, published on 1 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53009 exists.

Affected packages and fixed versions:
- materialx (PyPI): affected from 1.39.2; fixed in 1.39.3
- materialx (PyPI): affected from 1.39.2; fixed in 1.39.3
- MaterialX (PyPI): affected from 1.39.2; fixed in 1.39.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53009/ (Markdown: https://insights.sbomify.com/CVE-2025-53009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53009
- OSV: https://osv.dev/vulnerability/CVE-2025-53009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53009/
Summaries are generated and may contain mistakes; the official description above is the record.
