# CVE-2025-53011: MaterialX is Vulnerable to NULL Pointer Dereference due to Unchecked implGraphOutput

> An attacker can crash applications using MaterialX by providing a malicious MTLX file, causing a denial of service via null pointer dereference.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2025
- **Updated:** 1 Aug 2025
- **Also known as:** GHSA-7qw8-3vmf-gj32, PYSEC-2026-1607

## What is CVE-2025-53011?

CVE-2025-53011 is a low-severity vulnerability in AcademySoftwareFoundation MaterialX, published on 1 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

MaterialX is an open standard for the exchange of rich material and look-development content across applications and renderers. In version 1.39.2, when parsing shader nodes in a MTLX file, the MaterialXCore code accesses a potentially null pointer, which can lead to crashes with maliciously crafted files. An attacker could intentionally crash a target program that uses MaterialX by sending a malicious MTLX file. This is fixed in version 1.39.3.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2025-53011?

3 open source packages ship an affected version, including materialx and MaterialX. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `materialx` | PyPI | From 1.39.2 | 1.39.3 |
| `materialx` | PyPI | From 1.39.2 | 1.39.3 |
| `MaterialX` | PyPI | From 1.39.2 | 1.39.3 |

Products: Linuxfoundation Materialx.

## How do I fix CVE-2025-53011?

Upgrade materialx to 1.39.3 or later.

## Is CVE-2025-53011 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53011 exists.

## Other vulnerabilities in AcademySoftwareFoundation MaterialX

- [CVE-2025-53009](https://insights.sbomify.com/CVE-2025-53009/): MaterialX Stack Overflow via Lack of MTLX XML Parsing Recursion Limit (medium 5.5)
- [CVE-2025-53012](https://insights.sbomify.com/CVE-2025-53012/): MaterialX's Lack of Import Depth Limit Leads to DoS (Denial-Of-Service) Via Stack Exhaustion (medium 5.5)
- [CVE-2025-53010](https://insights.sbomify.com/CVE-2025-53010/): MaterialX's unchecked nodeGraph->getOutput return is vulnerable to NULL Pointer Dereference (low 2.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53011 and fix it if it is affected.

What it is: CVE-2025-53011 is a low-severity vulnerability in AcademySoftwareFoundation MaterialX, published on 1 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53011 exists.

Affected packages and fixed versions:
- materialx (PyPI): affected from 1.39.2; fixed in 1.39.3
- materialx (PyPI): affected from 1.39.2; fixed in 1.39.3
- MaterialX (PyPI): affected from 1.39.2; fixed in 1.39.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53011/ (Markdown: https://insights.sbomify.com/CVE-2025-53011/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53011
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53011
- OSV: https://osv.dev/vulnerability/CVE-2025-53011

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53011/
Summaries are generated and may contain mistakes; the official description above is the record.
