CVE-2025-53013 Himmelblau offline auth permits authentication with invalid Hello PIN
An attacker can bypass authentication on offline Linux hosts using Himmelblau by providing an invalid Hello PIN, gaining local system access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-53013?
CVE-2025-53013 is a medium-severity authentication bypass vulnerability in himmelblau-idm himmelblau, published on 26 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Himmelblau is an interoperability suite for Microsoft Azure Entra ID and Intune. A vulnerability present in versions 0.9.10 through 0.9.16 allows a user to authenticate to a Linux host via Himmelblau using an *invalid* Linux Hello PIN, provided the host is offline. While the user gains access to the local system, Single Sign-On (SSO) fails due to the network being down and the inability to issue tokens (due to a failure to unlock the Hello key). The core issue lies in an incorrect assumption within the `acquire_token_by_hello_for_business_key` function: it was expected to return a `TPMFail` error for an invalid Hello key when offline, but instead, a preceding nonce request resulted in a `RequestFailed` error, leading the system to erroneously transition to an offline success state without validating the Hello key unlock. This impacts systems using Himmelblau for authentication when operating in an offline state with Hello PIN authentication enabled. Rocky Linux 8 (and variants) are not affected by this vulnerability. The problem is resolved in Himmelblau version 0.9.17. A workaround is available for users who cannot immediately upgrade. Disabling Hello PIN authentication by setting `enable_hello = false` in `/etc/himmelblau/himmelblau.conf` will mitigate the vulnerability.
Weakness: CWE-287
Which versions are affected by CVE-2025-53013?
Linux distribution packages (1)
himmelblau openSUSE:Tumbleweed | All versions | 0.9.17+git.0.4a97692-1.1 |
How do I fix CVE-2025-53013?
Upgrade to a fixed version.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-53013 being exploited?
There is no known exploitation of CVE-2025-53013 in the wild and no public exploit code.
Sources
Also known as GHSA-j93j-pwm6-p97j, openSUSE-SU-2025:15229-1.