# CVE-2025-53019: ImageMagick has Memory Leak in magick stream

> Attackers can cause a memory leak in ImageMagick's stream command by using specific filename templates, potentially leading to denial of service.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2025
- **Updated:** 3 Nov 2025
- **Also known as:** CLSA-2025-1759145639, CLSA-2025-1759145882, DEBIAN-CVE-2025-53019, ECHO-6225-ad22-dd52, GHSA-cfh4-9f7v-fhrc, JLSEC-2026-917, MINI-549g-rg8x-9xq5, UBUNTU-CVE-2025-53019

## What is CVE-2025-53019?

CVE-2025-53019 is a low-severity denial of service vulnerability in Imagemagick Imagemagick, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. In versions prior to 7.1.2-0 and 6.9.13-26, in ImageMagick's `magick stream` command, specifying multiple consecutive `%d` format specifiers in a filename template causes a memory leak. Versions 7.1.2-0 and 6.9.13-26 fix the issue.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-53019?

36 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.7.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.7.0 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2025-53019?

Upgrade Magick.NET-Q16-AnyCPU to 14.7.0 or later.

## Is CVE-2025-53019 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53019 exists.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53019 and fix it if it is affected.

What it is: CVE-2025-53019 is a low-severity denial of service vulnerability in Imagemagick Imagemagick, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53019 exists.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.7.0
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53019/ (Markdown: https://insights.sbomify.com/CVE-2025-53019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53019
- OSV: https://osv.dev/vulnerability/CVE-2025-53019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53019/
Summaries are generated and may contain mistakes; the official description above is the record.
