CVE-2025-5302 Denial of Service (DOS) in JSONReader in run-llama/llama_index

High 8.6 Published Updated

Attackers can cause denial of service in llama_index by submitting deeply nested JSON files, triggering excessive recursion and resource consumption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-5302?

CVE-2025-5302 is a high-severity denial of service vulnerability in run-llama/llama_index, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

Weakness: CWE-674

Which versions are affected by CVE-2025-5302?

3 open source packages ship an affected version, including llama-index-core.

PackageAffectedFixed in
llama-index-core PyPIAll versions0.12.38
llama-index-core PyPIAll versions0.12.38
llama-index-core PyPIAll versions0.12.38

How do I fix CVE-2025-5302?

Upgrade llama-index-core to 0.12.38 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-5302 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5302 exists.

Sources

Also known as GHSA-7753-xrfw-ch36, PYSEC-2026-1561.

Is CVE-2025-5302 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free