# CVE-2025-5302: Denial of Service (DOS) in JSONReader in run-llama/llama_index

> Attackers can cause denial of service in llama_index by submitting deeply nested JSON files, triggering excessive recursion and resource consumption.

- **Severity:** High 8.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2025
- **Updated:** 25 Aug 2025
- **Also known as:** GHSA-7753-xrfw-ch36, PYSEC-2026-1561

## What is CVE-2025-5302?

CVE-2025-5302 is a high-severity denial of service vulnerability in run-llama/llama_index, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2025-5302?

3 open source packages ship an affected version, including llama-index-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | All versions | 0.12.38 |
| `llama-index-core` | PyPI | All versions | 0.12.38 |
| `llama-index-core` | PyPI | All versions | 0.12.38 |

## How do I fix CVE-2025-5302?

Upgrade llama-index-core to 0.12.38 or later.

## Is CVE-2025-5302 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5302 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5302 and fix it if it is affected.

What it is: CVE-2025-5302 is a high-severity denial of service vulnerability in run-llama/llama_index, published on 25 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5302 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected all versions; fixed in 0.12.38
- llama-index-core (PyPI): affected all versions; fixed in 0.12.38
- llama-index-core (PyPI): affected all versions; fixed in 0.12.38

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5302/ (Markdown: https://insights.sbomify.com/CVE-2025-5302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5302
- OSV: https://osv.dev/vulnerability/CVE-2025-5302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5302/
Summaries are generated and may contain mistakes; the official description above is the record.
