CVE-2025-53020 Apache HTTP Server: HTTP/2 DoS by Memory Increase
Attackers can cause a denial of service in Apache HTTP Server by triggering excessive memory consumption through HTTP/2 requests.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-53020?
CVE-2025-53020 is a high-severity denial of service vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server.
This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63.
Users are recommended to upgrade to version 2.4.64, which fixes the issue.
Weakness: CWE-401
Which versions are affected by CVE-2025-53020?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.17 | 2.4.64 |
Linux distribution packages (10)
mod_http2 AlmaLinux:10 | All versions | 2.0.29-4.el10_2 |
mod_http2 AlmaLinux:9 | All versions | 2.0.26-6.el9_8 |
mod_http2 Red Hat:enterprise_linux:10.2 | All versions | 0:2.0.29-4.el10_2 |
mod_http2-debuginfo Red Hat:enterprise_linux:10.2 | All versions | 0:2.0.29-4.el10_2 |
mod_http2-debugsource Red Hat:enterprise_linux:10.2 | All versions | 0:2.0.29-4.el10_2 |
mod_http2 Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-6.el9_8 |
mod_http2-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-6.el9_8 |
mod_http2-debugsource Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-6.el9_8 |
mod_http2 Rocky Linux:10 | All versions | 0:2.0.29-4.el10_2 |
mod_http2 Rocky Linux:9 | All versions | 0:2.0.26-6.el9_8 |
Products include Apache Http Server.
How do I fix CVE-2025-53020?
Upgrade apache to 2.4.64 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-53020 being exploited?
There is no known exploitation of CVE-2025-53020 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2025-53020, ALSA-2026:22528, ALSA-2026:22551, AZL-65094, AZL-65109, BELL-CVE-2025-53020 and 11 more.