# CVE-2025-53020: Apache HTTP Server: HTTP/2 DoS by Memory Increase

> Attackers can cause a denial of service in Apache HTTP Server by triggering excessive memory consumption through HTTP/2 requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2025-53020, ALSA-2026:22528, ALSA-2026:22551, AZL-65094, AZL-65109, BELL-CVE-2025-53020, BIT-apache-2025-53020, CLSA-2026-1781175625, CLSA-2026-1783416695, DEBIAN-CVE-2025-53020, GHSA-c2vf-6g7v-8m6c, MINI-j7mr-r439-jp3q, RHSA-2026:22528, RHSA-2026:22551, RLSA-2026:22528, RLSA-2026:22551, UBUNTU-CVE-2025-53020

## What is CVE-2025-53020?

CVE-2025-53020 is a high-severity denial of service vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server.

This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63.

Users are recommended to upgrade to version 2.4.64, which fixes the issue.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2025-53020?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.17 | 2.4.64 |
| `mod_http2` | AlmaLinux:10 | All versions | 2.0.29-4.el10_2 |
| `mod_http2` | AlmaLinux:9 | All versions | 2.0.26-6.el9_8 |
| `mod_http2` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.0.29-4.el10_2 |
| `mod_http2-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.0.29-4.el10_2 |
| `mod_http2-debugsource` | Red Hat:enterprise_linux:10.2 | All versions | 0:2.0.29-4.el10_2 |
| `mod_http2` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-6.el9_8 |
| `mod_http2-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-6.el9_8 |
| `mod_http2-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-6.el9_8 |
| `mod_http2` | Rocky Linux:10 | All versions | 0:2.0.29-4.el10_2 |
| `mod_http2` | Rocky Linux:9 | All versions | 0:2.0.26-6.el9_8 |

Products: Apache Http Server.

## How do I fix CVE-2025-53020?

Upgrade apache to 2.4.64 or later.

## Is CVE-2025-53020 being exploited?

There is no known exploitation of CVE-2025-53020 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2025-53020 - HPACK bombing for Apache HTTPD. (github_poc): https://github.com/galbarnahum/CVE-2025-53020-PoC

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53020 and fix it if it is affected.

What it is: CVE-2025-53020 is a high-severity denial of service vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53020 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.17; fixed in 2.4.64

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53020/ (Markdown: https://insights.sbomify.com/CVE-2025-53020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53020
- OSV: https://osv.dev/vulnerability/CVE-2025-53020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53020/
Summaries are generated and may contain mistakes; the official description above is the record.
