{"answers":{"affected":"3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53021 exists.","fix":"Upgrade moodle/moodle to 4.0.0 or later.","what":"CVE-2025-53021 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53021 and fix it if it is affected.\n\nWhat it is: CVE-2025-53021 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53021 exists.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.0.0; fixed in 4.0.0\n- moodle/moodle (Packagist): affected from 3.0.0; fixed in 4.0.0\n- moodle (Bitnami): affected from 3.0.0; fixed in 4.1.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53021/ (Markdown: https://insights.sbomify.com/CVE-2025-53021/index.md)","id":"CVE-2025-53021","markdown":"https://insights.sbomify.com/CVE-2025-53021/index.md","name":"CVE-2025-53021","record":{"aliases":["BIT-moodle-2025-53021","GHSA-cgvv-3455-824j","UBUNTU-CVE-2025-53021"],"analysis":{"component_type":"web_application","fix_type":"end_of_life","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Unauthenticated attackers can hijack user sessions via sesskey reuse in Moodle's OAuth2 flow, leading to full account takeover.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-384","name":"Session Fixation"}],"description":"A session fixation vulnerability in Moodle 3.x through 3.11.18 allows unauthenticated attackers to hijack user sessions via the sesskey parameter. The sesskey can be obtained without authentication and reused within the OAuth2 login flow, resulting in the victim's session being linked to the attacker's. Successful exploitation results in full account takeover. According to the Moodle Releases page, \"Bug fixes for security issues in 3.11.x ended 11 December 2023.\" NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Moodle Session Fixation allows unauthenticated users to hijack sessions via sesskey parameter","id":"CVE-2025-53021","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2025-53022"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.10"],"introduced":["3.0.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2025-53021"},{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["3.0.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-cgvv-3455-824j"},{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["3.0.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-cgvv-3455-824j"}],"prev":{"headline":"Apache HTTP Server: HTTP/2 DoS by Memory Increase","id":"CVE-2025-53020"},"products":["Moodle"],"published":"2025-06-24","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-24","vendors":["Moodle"]},"summary":"Unauthenticated attackers can hijack user sessions via sesskey reuse in Moodle's OAuth2 flow, leading to full account takeover.","url":"https://insights.sbomify.com/CVE-2025-53021/"}