# CVE-2025-53021: Moodle Session Fixation allows unauthenticated users to hijack sessions via sesskey parameter

> Unauthenticated attackers can hijack user sessions via sesskey reuse in Moodle's OAuth2 flow, leading to full account takeover.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** BIT-moodle-2025-53021, GHSA-cgvv-3455-824j, UBUNTU-CVE-2025-53021

## What is CVE-2025-53021?

CVE-2025-53021 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A session fixation vulnerability in Moodle 3.x through 3.11.18 allows unauthenticated attackers to hijack user sessions via the sesskey parameter. The sesskey can be obtained without authentication and reused within the OAuth2 login flow, resulting in the victim's session being linked to the attacker's. Successful exploitation results in full account takeover. According to the Moodle Releases page, "Bug fixes for security issues in 3.11.x ended 11 December 2023." NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2025-53021?

3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.0.0 | 4.0.0 |
| `moodle/moodle` | Packagist | From 3.0.0 | 4.0.0 |
| `moodle` | Bitnami | From 3.0.0 | 4.1.10 |

Products: Moodle Moodle.

## How do I fix CVE-2025-53021?

Upgrade moodle/moodle to 4.0.0 or later.

## Is CVE-2025-53021 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53021 exists.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53021 and fix it if it is affected.

What it is: CVE-2025-53021 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53021 exists.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.0.0; fixed in 4.0.0
- moodle/moodle (Packagist): affected from 3.0.0; fixed in 4.0.0
- moodle (Bitnami): affected from 3.0.0; fixed in 4.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53021/ (Markdown: https://insights.sbomify.com/CVE-2025-53021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53021
- OSV: https://osv.dev/vulnerability/CVE-2025-53021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53021/
Summaries are generated and may contain mistakes; the official description above is the record.
