{"answers":{"affected":"2 open source packages ship an affected version, including @strapi/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-53092 in the wild and no public exploit code.","fix":"Upgrade @strapi/core to 5.20.0 or later.","what":"CVE-2025-53092 is a medium-severity vulnerability in strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53092 and fix it if it is affected.\n\nWhat it is: CVE-2025-53092 is a medium-severity vulnerability in strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-53092 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @strapi/core (npm): affected all versions; fixed in 5.20.0\n- @strapi/core (npm): affected all versions; fixed in 5.20.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53092/ (Markdown: https://insights.sbomify.com/CVE-2025-53092/index.md)","id":"CVE-2025-53092","markdown":"https://insights.sbomify.com/CVE-2025-53092/index.md","name":"CVE-2025-53092","record":{"aliases":["GHSA-9329-mxxw-qwf8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Strapi headless CMS","requires_auth":"none","summary":"Strapi's default CORS configuration allows attackers to read sensitive data via credentialed cross-origin requests.","user_interaction":"required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"strapi","vendor":"strapi"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"},{"id":"CWE-364","name":"Signal Handler Race Condition"},{"id":"CWE-284","name":"Improper Access Control"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Strapi is an open source headless content management system. Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. This allows an attacker-controlled site to send credentialed requests to the Strapi backend. An attacker can exploit this by hosting a malicious site on a different origin (e.g., different port) and sending requests with credentials to the Strapi API. The vulnerability is fixed in version 5.20.0. No known workarounds exist.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Strapi core vulnerable to sensitive data exposure via CORS misconfiguration","id":"CVE-2025-53092","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"misconfiguration","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"TabberNeue vulnerable to Stored XSS through wikitext","id":"CVE-2025-53093"},"packages":[{"ecosystem":"npm","fixed":["5.20.0"],"introduced":["0"],"last_affected":[],"package":"@strapi/core","purl":null,"source":"GHSA-9329-mxxw-qwf8"},{"ecosystem":"npm","fixed":["5.20.0"],"introduced":["0"],"last_affected":[],"package":"@strapi/core","purl":"pkg:npm/%40strapi/core","source":"GHSA-9329-mxxw-qwf8"}],"prev":{"headline":"WeGIA has Unauthenticated Time-Based Blind SQL Injection in almox Parameter","id":"CVE-2025-53091"},"products":["strapi"],"published":"2025-10-16","related":[{"cvss_score":7.2,"headline":"Strapi Cleartext Storage of Sensitive Information","id":"CVE-2023-22894","kev_date_added":"2026-10-08","published":"2023-04-19"},{"cvss_score":10,"headline":"Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin","id":"CVE-2023-22621","kev_date_added":null,"published":"2023-04-19"},{"cvss_score":9.8,"headline":"Unrestricted Upload of File with Dangerous Type in Strapi","id":"CVE-2022-27263","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.8,"headline":"Authorization bypass in Strapi","id":"CVE-2020-27664","kev_date_added":null,"published":"2020-10-22"},{"cvss_score":9.8,"headline":"Strapi allows unauthenticated attacker to reset admin password without valid reset token","id":"CVE-2019-18818","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":9.3,"headline":"Strapi Vulnerable to SQL Injection in Content Type Builder","id":"CVE-2026-22599","kev_date_added":null,"published":"2026-05-14"},{"cvss_score":9.2,"headline":"Strapi may leak sensitive data via relational filtering due to lack of query sanitization","id":"CVE-2026-27886","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-16","vendors":["strapi"]},"summary":"Strapi's default CORS configuration allows attackers to read sensitive data via credentialed cross-origin requests.","url":"https://insights.sbomify.com/CVE-2025-53092/"}