# CVE-2025-53092: Strapi core vulnerable to sensitive data exposure via CORS misconfiguration

> Strapi's default CORS configuration allows attackers to read sensitive data via credentialed cross-origin requests.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 16 Oct 2025
- **Also known as:** GHSA-9329-mxxw-qwf8

## What is CVE-2025-53092?

CVE-2025-53092 is a medium-severity vulnerability in strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Strapi is an open source headless content management system. Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. This allows an attacker-controlled site to send credentialed requests to the Strapi backend. An attacker can exploit this by hosting a malicious site on a different origin (e.g., different port) and sending requests with credentials to the Strapi API. The vulnerability is fixed in version 5.20.0. No known workarounds exist.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains), CWE-364 (Signal Handler Race Condition), CWE-284 (Improper Access Control), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-53092?

2 open source packages ship an affected version, including @strapi/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/core` | npm | All versions | 5.20.0 |
| `@strapi/core` | npm | All versions | 5.20.0 |

Products: Strapi Strapi.

## How do I fix CVE-2025-53092?

Upgrade @strapi/core to 5.20.0 or later.

## Is CVE-2025-53092 being exploited?

There is no known exploitation of CVE-2025-53092 in the wild and no public exploit code.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53092 and fix it if it is affected.

What it is: CVE-2025-53092 is a medium-severity vulnerability in strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-53092 in the wild and no public exploit code.

Affected packages and fixed versions:
- @strapi/core (npm): affected all versions; fixed in 5.20.0
- @strapi/core (npm): affected all versions; fixed in 5.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53092/ (Markdown: https://insights.sbomify.com/CVE-2025-53092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53092
- OSV: https://osv.dev/vulnerability/CVE-2025-53092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53092/
Summaries are generated and may contain mistakes; the official description above is the record.
