# CVE-2025-53093: TabberNeue vulnerable to Stored XSS through wikitext

> Attackers can inject arbitrary HTML into the DOM via the tabber tag, enabling stored XSS attacks against MediaWiki users.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2025
- **Updated:** 27 Jun 2025
- **Also known as:** GHSA-jfj7-249r-7j2m

## What is CVE-2025-53093?

CVE-2025-53093 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-TabberNeue, published on 27 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TabberNeue is a MediaWiki extension that allows the wiki to create tabs. Starting in version 3.0.0 and prior to version 3.1.1, any user can insert arbitrary HTMLinto the DOM by inserting a payload into any allowed attribute of the `<tabber>` tag. Version 3.1.1 contains a patch for the bug.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-53093?

2 open source packages ship an affected version, including starcitizentools/tabber-neue.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starcitizentools/tabber-neue` | Packagist | From 3.0.0 | 3.1.1 |
| `starcitizentools/tabber-neue` | Packagist | From 3.0.0 | 3.1.1 |

## How do I fix CVE-2025-53093?

Upgrade starcitizentools/tabber-neue to 3.1.1 or later.

## Is CVE-2025-53093 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53093 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53093 and fix it if it is affected.

What it is: CVE-2025-53093 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-TabberNeue, published on 27 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53093 exists.

Affected packages and fixed versions:
- starcitizentools/tabber-neue (Packagist): affected from 3.0.0; fixed in 3.1.1
- starcitizentools/tabber-neue (Packagist): affected from 3.0.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53093/ (Markdown: https://insights.sbomify.com/CVE-2025-53093/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53093
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53093
- OSV: https://osv.dev/vulnerability/CVE-2025-53093

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53093/
Summaries are generated and may contain mistakes; the official description above is the record.
