# CVE-2025-53099: Sentry Missing Invalidation of Authorization Codes During OAuth Exchange and Revocation

> Attackers can maintain account persistence via race conditions in OAuth code handling, requiring self-hosted users to upgrade.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Jul 2025
- **Updated:** 1 Jul 2025
- **Also known as:** GHSA-mgh8-h4xc-pfmj

## What is CVE-2025-53099?

CVE-2025-53099 is a medium-severity vulnerability in getsentry sentry, published on 1 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Sentry is a developer-first error tracking and performance monitoring tool. Prior to version 25.5.0, an attacker with a malicious OAuth application registered with Sentry can take advantage of a race condition and improper handling of authorization code within Sentry to maintain persistence to a user's account. With a specially timed requests and redirect flows, an attacker could generate multiple authorization codes that could be used to exchange for access and refresh tokens. This was possible even after de-authorizing the particular application. This issue has been patched in version 25.5.0. Self-hosted Sentry users should upgrade to version 25.5.0 or higher. Sentry SaaS users do not need to take any action.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-53099?

It affects 1 product.


Products: Sentry Sentry.

## How do I fix CVE-2025-53099?

No fix has been published for CVE-2025-53099 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-53099 being exploited?

There is no known exploitation of CVE-2025-53099 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53099 and fix it if it is affected.

What it is: CVE-2025-53099 is a medium-severity vulnerability in getsentry sentry, published on 1 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-53099 in the wild and no public exploit code.

Affected product: getsentry sentry. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53099/ (Markdown: https://insights.sbomify.com/CVE-2025-53099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53099
- OSV: https://osv.dev/vulnerability/CVE-2025-53099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53099/
Summaries are generated and may contain mistakes; the official description above is the record.
