CVE-2025-53102 Discourse's WebAuthn challenge isn't cleared from user session after authentication

High 8.2 Published Updated

Attackers can reuse WebAuthn challenges to bypass two-factor authentication controls in Discourse forums.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-53102?

CVE-2025-53102 is a high-severity vulnerability in Discourse Discourse, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source community discussion platform. Prior to version 3.4.7 on the `stable` branch and version 3.5.0.beta.8 on the `tests-passed` branch, upon issuing a physical security key for 2FA, the server generates a WebAuthn challenge, which the client signs. The challenge is not cleared from the user’s session after authentication, potentially allowing reuse and increasing security risk. This is fixed in versions 3.4.7 and 3.5.0.beta.8.

Weakness: CWE-384

Which versions are affected by CVE-2025-53102?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.4.7

Products include Discourse Discourse.

How do I fix CVE-2025-53102?

Upgrade discourse to 3.4.7 or later.

Is CVE-2025-53102 being exploited?

There is no known exploitation of CVE-2025-53102 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-53102, GHSA-hv49-93h5-4wcv.

Is CVE-2025-53102 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free