# CVE-2025-53103: JUnit OpenTestReportGeneratingListener can leak Git credentials

> JUnit's Open Test Reporting listener may leak Git credentials in generated XML files, allowing attackers to steal tokens and impersonate users if reports are public.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jul 2025
- **Updated:** 1 Jul 2025
- **Also known as:** GHSA-m43g-m425-p68x, UBUNTU-CVE-2025-53103

## What is CVE-2025-53103?

CVE-2025-53103 is a medium-severity vulnerability in junit-team junit-framework, published on 1 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

JUnit is a testing framework for Java and the JVM. From version 5.12.0 to 5.13.1, JUnit's support for writing Open Test Reporting XML files can leak Git credentials. The impact depends on the level of the access token exposed through the OpenTestReportGeneratingListener. If these test reports are published or stored anywhere public, then there is the possibility that a rouge attacker can steal the token and perform elevated actions by impersonating the user or app. This issue as been patched in version 5.13.2.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2025-53103?

2 open source packages ship an affected version, including org.junit.platform:junit-platform-reporting.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.junit.platform:junit-platform-reporting` | Maven | From 5.12.0 | 5.13.2 |
| `org.junit.platform:junit-platform-reporting` | Maven | From 5.12.0 | 5.13.2 |

## How do I fix CVE-2025-53103?

Upgrade org.junit.platform:junit-platform-reporting to 5.13.2 or later.

## Is CVE-2025-53103 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53103 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53103 and fix it if it is affected.

What it is: CVE-2025-53103 is a medium-severity vulnerability in junit-team junit-framework, published on 1 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53103 exists.

Affected packages and fixed versions:
- org.junit.platform:junit-platform-reporting (Maven): affected from 5.12.0; fixed in 5.13.2
- org.junit.platform:junit-platform-reporting (Maven): affected from 5.12.0; fixed in 5.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53103/ (Markdown: https://insights.sbomify.com/CVE-2025-53103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53103
- OSV: https://osv.dev/vulnerability/CVE-2025-53103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53103/
Summaries are generated and may contain mistakes; the official description above is the record.
