# CVE-2025-53105: GLPI permits unauthorized rules execution order

> A low-privileged user can modify rule execution order in GLPI, potentially altering system behavior or gaining unauthorized control.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Aug 2025
- **Updated:** 27 Aug 2025
- **Also known as:** GHSA-334r-2682-95wc, UBUNTU-CVE-2025-53105

## What is CVE-2025-53105?

CVE-2025-53105 is a high-severity missing authorization vulnerability in glpi-project glpi, published on 27 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GLPI, which stands for Gestionnaire Libre de Parc Informatique, is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. In versions 10.0.0 to before 10.0.19, a connected user without administration rights can change the rules execution order. This issue has been patched in version 10.0.19.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-53105?


## How do I fix CVE-2025-53105?

No fix has been published for CVE-2025-53105 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-53105 being exploited?

There is no known exploitation of CVE-2025-53105 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53105 and fix it if it is affected.

What it is: CVE-2025-53105 is a high-severity missing authorization vulnerability in glpi-project glpi, published on 27 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53105 in the wild and no public exploit code.

Affected product: glpi-project glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53105/ (Markdown: https://insights.sbomify.com/CVE-2025-53105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53105
- OSV: https://osv.dev/vulnerability/CVE-2025-53105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53105/
Summaries are generated and may contain mistakes; the official description above is the record.
