CVE-2025-53106 Graylog vulnerable to privilege escalation through API tokens
Authenticated users can escalate privileges by creating API tokens for other users due to weak permission checks in Graylog.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-53106?
CVE-2025-53106 is a high-severity vulnerability in graylog2-server, published on 2 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Graylog is a free and open log management platform. In versions 6.2.0 to before 6.2.4 and 6.3.0-alpha.1 to before 6.3.0-rc.2, Graylog users can gain elevated privileges by creating and using API tokens for the local Administrator or any other user for whom the malicious user knows the ID. For the attack to succeed, the attacker needs a user account in Graylog. They can then proceed to issue hand-crafted requests to the Graylog REST API and exploit a weak permission check for token creation. This issue has been patched in versions 6.2.4 and 6.3.0-rc.2. A workaround involves disabling the respective configuration found in System > Configuration > Users > "Allow users to create personal access tokens".
Weakness: CWE-285
Which versions are affected by CVE-2025-53106?
4 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.graylog2:graylog2-server Maven | From 6.2.0 | 6.2.4 |
org.graylog2:graylog2-server Maven | From 6.2.0 | 6.2.4 |
org.graylog2:graylog2-server Maven | From 6.3.0-alpha.1 | 6.3.0-rc.2 |
org.graylog2:graylog2-server Maven | From 6.3.0-alpha.1 | 6.3.0-rc.2 |
Products include Graylog Graylog.
How do I fix CVE-2025-53106?
Upgrade org.graylog2:graylog2-server to a fixed version for your release line: 6.2.4 or 6.3.0-rc.2.
Is CVE-2025-53106 being exploited?
There is no known exploitation of CVE-2025-53106 in the wild and no public exploit code.
Other vulnerabilities in graylog2-server
- CVE-2021-37759 Information disclosure in n/a
- CVE-2021-37760 Information disclosure in n/a
- CVE-2026-1435 Incorrect management of session invalidation vulnerability in Graylog Web Interface
- CVE-2024-24824 graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request
- CVE-2020-15813 Improper Certificate Validation in Graylog
Sources
Also known as GHSA-3m86-c9x3-vwm9.