{"answers":{"affected":"4 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-53106 in the wild and no public exploit code.","fix":"Upgrade org.graylog2:graylog2-server to a fixed version for your release line: 6.2.4 or 6.3.0-rc.2.","what":"CVE-2025-53106 is a high-severity vulnerability in graylog2-server, published on 2 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53106 and fix it if it is affected.\n\nWhat it is: CVE-2025-53106 is a high-severity vulnerability in graylog2-server, published on 2 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-53106 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.graylog2:graylog2-server (Maven): affected from 6.2.0; fixed in 6.2.4\n- org.graylog2:graylog2-server (Maven): affected from 6.2.0; fixed in 6.2.4\n- org.graylog2:graylog2-server (Maven): affected from 6.3.0-alpha.1; fixed in 6.3.0-rc.2\n- org.graylog2:graylog2-server (Maven): affected from 6.3.0-alpha.1; fixed in 6.3.0-rc.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53106/ (Markdown: https://insights.sbomify.com/CVE-2025-53106/index.md)","id":"CVE-2025-53106","markdown":"https://insights.sbomify.com/CVE-2025-53106/index.md","name":"CVE-2025-53106","record":{"aliases":["GHSA-3m86-c9x3-vwm9"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Graylog log management","requires_auth":"low_privilege","summary":"Authenticated users can escalate privileges by creating API tokens for other users due to weak permission checks in Graylog.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"graylog","vendor":"graylog"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Graylog is a free and open log management platform. In versions 6.2.0 to before 6.2.4 and 6.3.0-alpha.1 to before 6.3.0-rc.2, Graylog users can gain elevated privileges by creating and using API tokens for the local Administrator or any other user for whom the malicious user knows the ID. For the attack to succeed, the attacker needs a user account in Graylog. They can then proceed to issue hand-crafted requests to the Graylog REST API and exploit a weak permission check for token creation. This issue has been patched in versions 6.2.4 and 6.3.0-rc.2. A workaround involves disabling the respective configuration found in System \u003e Configuration \u003e Users \u003e \"Allow users to create personal access tokens\".","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Graylog vulnerable to privilege escalation through API tokens","id":"CVE-2025-53106","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"@cyanheads/git-mcp-server vulnerable to command injection in several tools","id":"CVE-2025-53107"},"packages":[{"ecosystem":"Maven","fixed":["6.2.4"],"introduced":["6.2.0"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":null,"source":"GHSA-3m86-c9x3-vwm9"},{"ecosystem":"Maven","fixed":["6.2.4"],"introduced":["6.2.0"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":"pkg:maven/org.graylog2/graylog2-server","source":"GHSA-3m86-c9x3-vwm9"},{"ecosystem":"Maven","fixed":["6.3.0-rc.2"],"introduced":["6.3.0-alpha.1"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":null,"source":"GHSA-3m86-c9x3-vwm9"},{"ecosystem":"Maven","fixed":["6.3.0-rc.2"],"introduced":["6.3.0-alpha.1"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":"pkg:maven/org.graylog2/graylog2-server","source":"GHSA-3m86-c9x3-vwm9"}],"prev":{"headline":"GLPI permits unauthorized rules execution order","id":"CVE-2025-53105"},"products":["graylog2-server"],"published":"2025-07-02","related":[{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2021-37759","kev_date_added":null,"published":"2021-07-31"},{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2021-37760","kev_date_added":null,"published":"2021-07-31"},{"cvss_score":9.3,"headline":"Incorrect management of session invalidation vulnerability in Graylog Web Interface","id":"CVE-2026-1435","kev_date_added":null,"published":"2026-02-18"},{"cvss_score":8.8,"headline":"graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request","id":"CVE-2024-24824","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":8.1,"headline":"Improper Certificate Validation in Graylog","id":"CVE-2020-15813","kev_date_added":null,"published":"2020-07-17"},{"cvss_score":8,"headline":"Graylog Allows Session Takeover via Insufficient HTML Sanitization","id":"CVE-2025-46827","kev_date_added":null,"published":"2025-05-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-02","vendors":["Graylog2"]},"summary":"Authenticated users can escalate privileges by creating API tokens for other users due to weak permission checks in Graylog.","url":"https://insights.sbomify.com/CVE-2025-53106/"}