# CVE-2025-53106: Graylog vulnerable to privilege escalation through API tokens

> Authenticated users can escalate privileges by creating API tokens for other users due to weak permission checks in Graylog.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jul 2025
- **Updated:** 2 Jul 2025
- **Also known as:** GHSA-3m86-c9x3-vwm9

## What is CVE-2025-53106?

CVE-2025-53106 is a high-severity vulnerability in graylog2-server, published on 2 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Graylog is a free and open log management platform. In versions 6.2.0 to before 6.2.4 and 6.3.0-alpha.1 to before 6.3.0-rc.2, Graylog users can gain elevated privileges by creating and using API tokens for the local Administrator or any other user for whom the malicious user knows the ID. For the attack to succeed, the attacker needs a user account in Graylog. They can then proceed to issue hand-crafted requests to the Graylog REST API and exploit a weak permission check for token creation. This issue has been patched in versions 6.2.4 and 6.3.0-rc.2. A workaround involves disabling the respective configuration found in System > Configuration > Users > "Allow users to create personal access tokens".

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-53106?

4 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.graylog2:graylog2-server` | Maven | From 6.2.0 | 6.2.4 |
| `org.graylog2:graylog2-server` | Maven | From 6.2.0 | 6.2.4 |
| `org.graylog2:graylog2-server` | Maven | From 6.3.0-alpha.1 | 6.3.0-rc.2 |
| `org.graylog2:graylog2-server` | Maven | From 6.3.0-alpha.1 | 6.3.0-rc.2 |

Products: Graylog Graylog.

## How do I fix CVE-2025-53106?

Upgrade org.graylog2:graylog2-server to a fixed version for your release line: 6.2.4 or 6.3.0-rc.2.

## Is CVE-2025-53106 being exploited?

There is no known exploitation of CVE-2025-53106 in the wild and no public exploit code.

## Other vulnerabilities in graylog2-server

- [CVE-2021-37759](https://insights.sbomify.com/CVE-2021-37759/): Information disclosure in n/a (critical 9.8)
- [CVE-2021-37760](https://insights.sbomify.com/CVE-2021-37760/): Information disclosure in n/a (critical 9.8)
- [CVE-2026-1435](https://insights.sbomify.com/CVE-2026-1435/): Incorrect management of session invalidation vulnerability in Graylog Web Interface (critical 9.3)
- [CVE-2024-24824](https://insights.sbomify.com/CVE-2024-24824/): graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request (high 8.8)
- [CVE-2020-15813](https://insights.sbomify.com/CVE-2020-15813/): Improper Certificate Validation in Graylog (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53106 and fix it if it is affected.

What it is: CVE-2025-53106 is a high-severity vulnerability in graylog2-server, published on 2 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-53106 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.graylog2:graylog2-server (Maven): affected from 6.2.0; fixed in 6.2.4
- org.graylog2:graylog2-server (Maven): affected from 6.2.0; fixed in 6.2.4
- org.graylog2:graylog2-server (Maven): affected from 6.3.0-alpha.1; fixed in 6.3.0-rc.2
- org.graylog2:graylog2-server (Maven): affected from 6.3.0-alpha.1; fixed in 6.3.0-rc.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53106/ (Markdown: https://insights.sbomify.com/CVE-2025-53106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53106
- OSV: https://osv.dev/vulnerability/CVE-2025-53106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53106/
Summaries are generated and may contain mistakes; the official description above is the record.
